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 “Skills and Drills” Learning

Rank Your Skills
Before starting this book, complete the skills assessment on the next page.



How This Assessment Works
Below you will find 10 course objectives for learning Adobe RoboHelp 2022. Before starting this book,
review each objective and rank your skills using the scale next to each objective. A rank of  means No 
Confidence in the skill. A rank of  means Total Confidence. After you’ve completed this assessment, 
work through the entire book. After finishing the book, review each objective and rank your skills now that 
you’ve completed the book. Most people see dramatic improvements in the second assessment after 
completing the lessons in this book.

Before Starting
1. I can create topics.     

2. I can create a table of contents.     

3. I can create hyperlinks to topics.     

4. I can create a cascading style sheet (css).     

5. I can create a variable.     

6. I can create conditional build expressions.     

7. I can create a snippet.     

8. I can customize an output template.     

9. I can create a map file.     

10. I can publish a project.     

Now That I Am Finished
1. I can create topics.     

2. I can create a table of contents.     

3. I can create hyperlinks to topics.     

4. I can create a cascading style sheet (css).     

5. I can create a variable.     

6. I can create conditional build expressions.     

7. I can create a snippet.     

8. I can customize an output template.     

9. I can create a map file.     

10. I can publish a project.      

IconLogic, Inc.
www.iconlogic.com

Skills Assessment
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About This Book
This Section Contains Information About:

• The Author, page viii
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The Author
Kevin Siegel is a Certified Technical Trainer (CTT), Certified Master Trainer 
(CMT), and Certified Online Training Professional (COTP). Kevin served in the 
U.S. Coast Guard, where he was twice decorated with the Coast Guard’s 
Achievement Medal. He also received the coveted Alex Haley Award for writing 
and photojournalism. 

Kevin has spent decades as a technical communicator, face-to-face and virtual 
trainer, eLearning developer, publisher, and keynote speaker. Kevin has written 
hundreds of books for adult learners. Some of his best-selling titles include “Adobe Captivate: The 
Essentials,” “Adobe RoboHelp: The Essentials,” “Articulate Storyline: The Essentials,” “Articulate 
Rise: The Essentials,” and “TechSmith Camtasia: The Essentials.”

IconLogic
Founded by Kevin in 1992, IconLogic is a training, development, and publishing company offering 
services to clients across the globe. 

As a training company, IconLogic has directly trained tens of thousands of professionals both on-
site and online on dozens of applications. Our training clients include some of the largest 
companies in the world including Adobe Systems, Inc., Urogen Pharma, Agilent Technologies, 
Sanofi Pasteur, Kelsey-Seybold Clinic, FAA, Office Pro, Adventist Health Systems, AGA, AAA, 
Wells Fargo, VA.gov, American Express, Lockheed Martin, General Mills, Grange Insurance, 
General Dynamics Electric Boat, Michigan.gov, Freddie Mac, Fannie Mae, ADP, ADT, Federal 
Reserve Bank of Richmond, Walmart, Kroger, Duke Energy, USCG, USMC, Canadian Blood, 
PSA, Department of Homeland Security, and the Department of Defense.

As a development company, IconLogic has produced eLearning and technical documentation for 
Duke Energy, World Bank, Heineken, EVERFI, Bank of America, Fresenius Kabi, Wells Fargo, 
Federal Express, Fannie Mae, American Express, Microsoft, Department of For-Hire Vehicles, 
DC Child and Family Services Agency, DCORM, Canadian Blood Services, Cancer.org, MLB, 
Archrock, NEEF, CHUBB Limited, Canadian Natural Resources, and Hagerty Insurance.

As a publishing company, IconLogic has published hundreds of critically acclaimed books and 
created technical documents for both print and digital publication. Some of our most popular titles 
over the years include books on HTML, Virtual Reality, Dreamweaver, QuarkXPress, PageMaker, 
InDesign, Word, Excel, Access, Publisher, RoboHelp, RoboDemo, iSpring Suite, Presenter, 
Storyline, Captivate, Camtasia, and PowerPoint.

You can learn more about IconLogic’s varied services at www.iconlogic.com.
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Book Conventions
In our experience, humans learn best by doing, not just by watching or listening. With this concept 
in mind, instructors and authors with years of experience training adult learners have created 
IconLogic books.

IconLogic books typically contain a minimal amount of text and are loaded with hands-on 
activities, screen captures, and challenge exercises to reinforce newly acquired skills. This book 
is divided into modules. Because each module builds on lessons learned in a previous module, 
we recommend that you complete each module in succession. 

Lesson Key
Instructions for you to follow look like this:

 choose File > Open

If you are expected to type anything or if something is important, it is set in bold type like this:

 type 9 into the text field

If you are expected to press a key on your keyboard, the instruction looks like this:

 press [shift]

Confidence Checks
As you work through this book, you will come across the image at the right 
(which indicates a Confidence Check). Throughout each module, you are 
guided through hands-on, step-by-step activities. To help ensure that you are 
understanding the book’s content, Confidence Checks encourage you to 
complete a process or steps on your own without step-by-step guidance. 
Because some of the book’s activities build on completed Confidence Checks, 
you should complete each of the activities and Confidence Checks in order.
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RoboHelp Updates and How They Affect This Book
With each major update of RoboHelp, my intention is to provide a book to support that version 
and make it available within 30-60 days of the software being released by Adobe. 

From time to time, Adobe releases updates for RoboHelp to fix bugs or add functionality. Usually, 
the updates are minor and have little or no impact on the lessons in this book. However, Adobe 
does sometimes make significant changes to the way RoboHelp looks or behaves, even with a 
seemingly minor update. 

If something on your screen does not match what is shown in this book, please visit the RoboHelp 
2022 book page on the IconLogic website for possible book updates or errata information (http://
www.iconlogic.com/adobe-robohelp-2022-essentials-workbook.html) or email me at 
ksiegel@iconlogic.com.

Software Requirements for This Book
Before you start the lessons in this book, install the Adobe RoboHelp 2022 software on your 
computer. The RoboHelp software does not come with this book, nor can it be downloaded from 
the IconLogic website. Purchase the program or download a free 30-day trial version from Adobe 
at www.adobe.com/products/robohelp.html.

Downloadable Book Assets (RoboHelp2022Data)
You’re probably eager to dive into RoboHelp and begin creating awesome Help Systems. As 
you’ll learn as you work through this book, all you need to create help systems on your own is 
Adobe RoboHelp and some content. 

Wait, content? What content? You’ll need text files, images, multimedia... the list of supporting 
assets you’ll need to create even a basic help system could go on and on.

If you have never used Adobe RoboHelp before, and this book assumes that you have not, I do 
not expect you to learn RoboHelp now, on-the-fly, and come up with content. Learning on-the-fly 
can be fine, but that takes, and wastes, time.

I’ve got a deal for you. You provide the computer, the Adobe RoboHelp 2022 software (the free 
trial version works great), and a willingness to learn. I’ll provide all of the project files and 
supporting assets (topic content, images, and videos) to get you started.

Here are the steps you need to download the free book assets from my website:

1. Start your web browser and go to the following web address:  
http://www.iconlogic.com/pc.htm

2. Click the Data Files link.

3. Choose your operating system (PC or Mac).

4. Select RoboHelp 2022: The Essentials.

5. Save the zip file to your computer. (It’s a good idea to note where the zip downloads so 
you can find it during the next step.)
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6. After the RoboHelp2022Data.zip file has fully downloaded, you can close the browser. 

7. Find the RoboHelp2022Data.zip file you just downloaded and unzip it. (On the Mac, the 
zip is typically extracted automatically.)

Although you can unzip the assets anywhere on your computer, the desktop usually 
works well. If you have an unzipped folder on your computer called RoboHelp2022Data 
and the Adobe RoboHelp 2020 software, you’re good to go.
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Project Scenarios
As you work through the activities in this book, I’m going to ask you to use your imagination and 
pretend that you are a technical communicator for an awesome, but fictional, company called 
Super Simplistic Solutions. As a technical communicator, it is your job to create all of the 
documentation for the company’s products, services, and internal policies and procedures. 

During the lessons presented in this book, you will use Adobe RoboHelp 2022 to create a Policies 
and Procedures guide that can be used by employees via a desktop computer, a laptop, 
smartphone, or tablet. 

Although the information you create in the upcoming policies guide is fictional, the content will 
likely seem similar to information in many corporate policy guides. Nevertheless, none of the 
information in the guide is based on real people, events, or companies. Any similarities are purely 
coincidental.

Contacting IconLogic
Web: www.iconlogic.com 
Email: ksiegel@iconlogic.com 
Phone: 410.956.4949, ext 711
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Module 1: Introduction 
to RoboHelp
In This Module You Will Learn About:

• RoboHelp’s History, page 2

• Exploring RoboHelp, page 3

• Topics, page 8

• Table of Contents and Indexes, page 11

• Frameless Output, page 13

And You Will Learn To:
• Open an Existing Project, page 3

• Set the RoboHelp Application Theme, page 5

• Explore Project Content, page 6

• Create, Edit, and Delete a Topic, page 8

• Explore a TOC and an Index, page 11

• Browse the Outputs, page 13

• Generate Frameless Output, page 14

• Generate Responsive HTML5 Output, page 17

• Generate an eBook, page 18

• Generate Microsoft HTML Help, page 19
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RoboHelp’s History
According to Adobe, “RoboHelp is an easy-to-use authoring and publishing solution.” Adobe also 
says that RoboHelp allows you to “deliver content to tablets, smartphones, and desktops using 
output formats such as Responsive HTML5.” 

Everything Adobe says about RoboHelp is true, and you’ll see that for yourself as you work with 
RoboHelp via the lessons in this book.

I started using RoboHelp when it was owned by a company called Blue Sky Software. That 
company re-branded itself as eHelp Corporation. Later, eHelp was absorbed by Macromedia 
(of Dreamweaver and Director fame), which was, in turn, gobbled up by Adobe. 

There have been several versions of RoboHelp over the years (see the table below). RoboHelp 
versions have included names like RoboHelp 5, 6, 7, 2002, X3, X4, and X5. RoboHelp 6 was 
Adobe’s first RoboHelp version. However, eHelp Corporation also had a RoboHelp version 6. 
Yes, that’s right. There was once eHelp RoboHelp 6, and there was an Adobe RoboHelp 6, 
creating a bit of customer confusion. 

Starting with RoboHelp 2015, Adobe changed RoboHelp’s naming convention again, this time 
using the year that the software version was released.

While this book focuses exclusively on RoboHelp 2022 and is titled, “Adobe RoboHelp 2022: 
The Essentials,” RoboHelp 2022 is really RoboHelp version 24.

Here is a list of RoboHelp versions and their release dates.

Version Release date Company/Note

1.0 January 1992 Blue Sky Software 
First generally-available version of RoboHelp

2.0–12.0 1993–2003 Blue Sky Software/eHelp Corporation

13.0 January 2004 Macromedia

14.0 January 2007 Adobe Systems, Inc.

15.0 September 2007 Adobe Systems, Inc.

16.0 January 2009 Adobe Systems, Inc.

17.0 January 2011 Adobe Systems, Inc.

18.0 July 2012 Adobe Systems, Inc.

19.0 January 2014 Adobe Systems, Inc.

20.0 June 2015 Adobe Systems, Inc.

21.0 January 2017 Adobe Systems, Inc.

22.0 August 2018 Adobe Systems, Inc.

23.0 July 2020 Adobe Systems, Inc.

24.0 September 2022 Adobe Systems, Inc.
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Exploring RoboHelp
During the lessons in this module, you will open a completed RoboHelp project, explore it a bit, 
and then generate outputs. As you work through subsequent modules in this book, you will learn 
how to build the completed project you’re about to see from scratch.

Note: To complete the first activity below, you will need the RoboHelp2022Data folder on your 
computer (also known as data files or assets). If you have not already downloaded the data files 
to your hard drive, see page x in the About This Book section of this book for instructions. 
The RoboHelp software is not included with this book. If you do not have RoboHelp installed on 
your computer, you can purchase the software, or download a 30-day trial, from Adobe at 
www.adobe.com/products/robohelp.html.

Guided Activity 1: Open an Existing Project
1. Start Adobe RoboHelp 2022.

After starting RoboHelp, the first thing you will see is the Starter Screen. From here, you 
can open recent projects, create new projects, and find additional resources. If the Starter 
is not on your screen, you can choose View > Starter Screen to view it.

2. Open an existing project from the RoboHelp2022Data folder.

 on the Starter Screen, click Open Project

 navigate to and open the RoboHelp2022Data folder

The RoboHelp2022Data folder contains several assets that support the lessons in this 
book, including images, HTML files, Word documents, and existing RoboHelp projects. 
You’ll be instructed when and how to use these assets as you work through the lessons in 
this book.

 open the RoboHelpProjects folder and then open the completed_project folder

There are several subfolders within the completed_project folder. Cumulatively, all of the 
assets within those folders support the main RoboHelp project file (the project file’s name 
is completed_project.rhpj). 

 open completed_project.rhpj

When opening a project, you may see a 
message similar to what is shown at 
the right. The message appears if your 
version of RoboHelp is even slightly 
different than the one used to create 
the projects for this book. If you see the 
message shown at the right, click the 
Upgrade button.
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The image below shows the PC version of RoboHelp 2022. RoboHelp is nearly identical 
on the Mac and PC. Because the interfaces are so similar, I’ll randomly show one platform 
or the other throughout this book. Should there be significant differences between the Mac 
and PC version of RoboHelp, I’ll note those differences as appropriate.

The completed project is a corporate policies and procedures guide for a company called 
Super Simplistic Solutions. During the activities presented throughout this book, you 
will learn how to create a similar project from scratch. 

Before moving forward, I’d like to explain the role of the rhpj project file that you opened a 
moment ago. The image below shows the contents of the completed_project folder. 
Notice that the rhpj file is only 3 KB. Although it’s small and does not contain any project 
content, the rhpj file has a critical job. The project file keeps track of content, links, 
images, multimedia, table of contents, indexes, and other critical behind-the-scenes 
functions.

While it’s certainly important, the rhpj file is by no means the RoboHelp project. Everything 
you see in the image above is an important project component. When it’s time to back up 
your work (and I encourage you to back up the project folder at least once per day), back 
up the entire project folder instead of just some of the files within the project folder.
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Guided Activity 2: Set the RoboHelp Application Theme
1. Ensure that the completed_project is still open. (If you’re not sure how to open the 

RoboHelp project, see page 3.)

2. Change the Theme.

 PC users, choose Edit > Preferences; 
Mac users, choose Adobe RoboHelp 2022 > Preferences

The Application Preferences dialog box opens. Changes you make here will affect all 
RoboHelp projects created or opened on your computer.

 at the left of the dialog box, select General

 from the Theme drop-down menu, choose Dark

The RoboHelp interface instantly switches from a light interface to dark. There are four 
RoboHelp Themes ranging from light to very dark. Personally, I like the contrast offered 
with the Dark Theme. The color scheme you use in RoboHelp is, of course, up to you.

 select any Theme that you like

 ensure that the remaining General settings match what is shown in the image below

 click the Done button
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Guided Activity 3: Explore Project Content
1. Ensure that the completed_project is still open. (If you’re not sure how to open a 

RoboHelp project, see page 3.)

2. Explore the Author area.

 from the upper left of the RoboHelp interface, notice that there are three tabs: 
Author, Output, and Review

 from the upper left of the RoboHelp interface, click Author

When you work in RoboHelp, you create or import content while working in the Author 
area. When you’re done authoring, you’ll use the Output area to generate your content 
into a format appropriate for users who will not have Adobe RoboHelp on their computers 
or devices. The Review area is where you will set up your project content for internal 
review and feedback from your team members and stakeholders.

 from the Author area, click Contents

The project contents open. If the Contents area does not open, try clicking Contents one 
more time.

 from the Contents panel, double-click the General 
Office Information folder to expand the folder and 
view its content

Note: If you see file names in the Contents panel, such as 
Electronic.htm instead of Electronic Communications 
Policy, choose View > Show > Topics by Title.

3. Open a topic.

 from the list of items in the General Office Information folder, double-click 
Mission Statement 
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4. Open a second topic.

 from the Contents panel, open the Drugs and Alcohol folder

 double-click Alcohol Policy

Two topics are now open in the Authoring area.

5. Switch between open topics.

 from just above either open topic, click the topic’s title tab to switch between the 
two topics

Note: While you can have multiple topics open at one time and quickly switch 
between them, you can only edit the content in the active topic. The active topic is 
denoted by the horizontal line beneath the topic’s title. In the image below, two 
topics are open: Mission Statement and Alcohol Policy. The Alcohol Policy topic is 
the active topic.

6. Close multiple topics.

 choose File > Close All

7. Close all expanded folders.

 on the Contents panel, right-click any folder and choose Collapse All
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Topics
You’ve likely heard the saying that content is king. It’s true. The heart of any Help System is its 
content and the information it provides. Most of the content in a RoboHelp project is contained 
within topics. Topics typically consist of text formatted with styles (page 43), images (page 80), 
hyperlinks (page 69), videos (page 89), tables (page 120), and more. In the next few activities, 
you will create, modify, and delete a topic.

Guided Activity 4: Create, Edit, and Delete a Topic
1. Ensure that the completed_project is still open. (If you’re not sure how to open the 

RoboHelp project, refer to page 3.)

2. Create a new topic.

 on the Contents panel, right-click beneath the last folder 

 choose New > Topic

The New Topic dialog box opens.

 change the Title to My First New Topic

 from the bottom of the dialog box, click the Create button

The new topic appears on the Content panel and opens for editing.
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3. Edit the new topic.

 click in the white space below the heading “My First New Topic”

 type: The best Help topic will contain only enough text to get my point across 
and no more. One paragraph or two is ideal, supported by an image or two.

Above your new topic, observe the asterisk to the right of the topic’s title. 

The asterisk indicates an unsaved topic. 

4. Save and close the topic.

 choose File > Save

The asterisk is removed, indicating that changes made to the topic have been saved. 

 choose File > Close

5. Delete a topic.

 on the Contents panel, right-click the My First New Topic topic and choose Delete

You will be asked to confirm the action.

 click the Yes button
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Adding and Deleting Topics Confidence Check
1. Create a new topic titled My Second Topic.

2. Change the title of the new topic to Delete Me.

3. Delete the Delete Me topic.
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Table of Contents and Indexes
A Table of Contents (TOC) provides users with a high-level overview of the content in your 
RoboHelp project. The order of the content in a TOC is typically based on a logical organization 
of information that you set up when you build the project. Of course, that logical structure won’t 
necessarily make sense to your users. So while a TOC is important, it will not be the first thing 
used when someone seeks help on a specific topic. Instead, users will likely turn to the Index 
or Search.

Unlike a TOC, which is most often a logical organization of content, an Index is an alphabetical 
listing of keywords, each targeted toward a specific topic. Users can quickly scan the list of 
keywords, find what they’re looking for, and click the keyword to display the appropriate content.

Guided Activity 5: Explore a TOC and an Index
1. Ensure that the completed_project is still open.

2. Open an existing TOC.

 from the panel at the far left, click Table of Contents

This project contains one TOC named policies.

 double-click policies to open the TOC

You will learn how to create a Table of Contents like this one beginning on page 39.
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3. Open an existing Index.

 from the panel at the far left, click Index

You will learn how to create an Index similar to this one beginning on page 127.



Module 1: Introduction to RoboHelp > Frameless Output > Browse the Outputs

© 2022, IconLogic, Inc. All Rights Reserved. 13

Frameless Output
If you’d like to get a sense of what your users will experience when accessing your finished 
RoboHelp project, you need to create output files from the project’s content. Your users do not 
need RoboHelp to open the output you create with RoboHelp. However, depending upon the type 
of output you generate, the users’ hardware and software needed to open the output will vary.

Frameless output can be viewed on the web or using a desktop application. This output works 
with any web browser, on Macs, PCs, and is highly customizable. When you generate Frameless 
output, you’re creating a self-contained website with several codependent files that must always 
be kept together to ensure that the Help System works as designed.

Guided Activity 6: Browse the Outputs
1. Ensure that the completed_project is still open.

2. View the current outputs.

 from the upper left of the RoboHelp window, 
click Output

 from the list at the left, click Output Presets

This project has a few outputs. There are several more outputs than those shown and you 
will explore some of them soon enough. Note that there is an output shown in the image 
below called Microsoft HTML Help. This output is unique to PC users. Because Mac’s 
cannot open this type of output, it is not available in RoboHelp for Mac.

 

3. View all of RoboHelp’s output formats.

 to the right of Output Presets, click the plus sign

The New Preset dialog box opens.

 click the Type drop-down menu

Notice that RoboHelp can output Chatbots, Content Only, eBooks, Frameless, Knowledge 
Base, MicroHelp, Mobile App, and more. 

 click on any of the Preset names to collapse the Type drop-down menu

 click the Cancel button
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Guided Activity 7: Generate Frameless Output
1. Ensure that the completed_project is still open.

2. Generate and view Frameless output.

 from among the Output Presets, double-click the Policies Output to open the output 
for editing

When an output is added to a project, it can be given any name. The developer who 
added the Frameless output elected to not use the name Frameless and instead went 
with the name Policies.

 select the General category

 from the Output Path area, click the Browse icon

 browse to and Select (PC) or Open (Mac):  
RoboHelp2022Data > output > Frameless

3. Close the Preset. (Save it when prompted.)
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4. Generate Frameless output.

 right-click Policies Output and choose Generate

You’ll see your Output Generation progress in the lower right of the RoboHelp window.

 

5. View the generated Frameless output.

 from the Output presets area, right-click Policies Output and choose View Output
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The Help System opens within your computer’s default web browser.

6. Spend a few minutes exploring the output by clicking the thumbnail images.

I personally love the look of the Frameless output, and it’s completely customizable. I also 
love how the page content reflows nicely as the browser window is resized.

7. When finished exploring the output, close the browser window and return to RoboHelp.
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Responsive HTML5 Output
The sale of smartphones exceeds the sale of traditional phones; the sale of tablets exceeds those 
of desktop computers. These trends have led to a need for help authors to create content that can 
be accessed from both mobile devices and traditional computers. 

When you output Responsive HTML5 with RoboHelp, just about everything in the Help window 
reflows, resizes, and adjusts to provide optimal viewing across a wide range of devices and 
screen sizes.

Guided Activity 8: Generate Responsive HTML5 Output
1. Ensure that the completed_project is still open.

2. Generate and view Responsive HTML5 output.

 from among the Output Presets, double-click Responsive HTML5 to open the layout

 select the General category

 from the Output Path area, click the Browse icon 

 browse to and Select (PC) or Open (Mac): 
RoboHelp2022Data > output > Responsive HTML5

 close and save the Responsive HTML5 preset

 right-click the Responsive HTML5 preset and choose Generate

3. View the Output.

4. Resize the browser window.

Similar to the Frameless output, observe how the appearance of the page changes 
(responds) as you resize the browser window.

5. Close the browser window and return to the RoboHelp project.
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eBooks
You have learned that RoboHelp easily outputs web content by generating Frameless and 
Responsive HTML5. You can also use RoboHelp to generate an eBook (also known as an ePub 
or Kindle). When opened with an eBook reader, the text wraps to fit the size of the user’s device 
or display. The user can control the font, font size, and font color. Although the eBook format is 
flexible, it does not currently support all of the bells and whistles that you can add to a RoboHelp 
project. For instance, eBook readers do not support expanding hotspots, glossaries, or interactive 
eLearning videos. (You will learn how to add these features later in this book.)

Note: In the steps that follow, you will use RoboHelp to generate an eBook. After 
the eBook file has been created, you will need an eBook reader to open the eBook 
file. There are many eBook readers (some free, some not). Here is a list of free 
eBook readers: https://www.techradar.com/best/best-free-ebook-reader.
For more information on the eBook format, visit https://www.w3.org/publishing/.

Guided Activity 9: Generate an eBook
1. Ensure that the completed_project is still open.

2. Output an eBook.

 from among the Output Presets, double-click eBook to open it

 select the General category

 from the Output Path area, click the Browse icon 

 browse to and open/select: RoboHelp2022Data > output > eBook

 close and save the eBook preset

 right-click the eBook Preset and choose Generate

3. View the eBook output.

The eBook opens in your computer’s default ePub reader. In the image at the right, you 
can see a page from the EPUB as it appears using the Calibre reader for the Mac.

4. Close the eBook file.

5. Return to the RoboHelp project.

The last activity in this module involves outputting Microsoft HTML Help and is for PC 
users only. Mac users, you can close the project and then move on to the next module.
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Microsoft HTML Help
Microsoft HTML Help (HTML Help for short) is the oldest of the outputs and can be created and 
used only by PC users. When you generate HTML Help, RoboHelp outputs a single, compressed 
CHM file (pronounced “chum”). 

A CHM file works great if your users are accessing the Help System with a Windows-based PC 
and if the CHM file is installed on the user’s hard drive. CHM files do not work if your users access 
the Help System with a computer or laptop running any other operating system, or if the user is on 
a mobile device, such as a tablet or smart phone. CHM files do not work well if opened by users 
over a server. And there are limits on how much you can customize the look and feel of the HTML 
Help window. 

Given the limitations of a CHM file, you might think that HTML Help is an output that is best 
avoided. Not necessarily. There is much to like about CHM files. For instance, HTML Help files 
are self-contained Help Systems, and your users won’t need other programs to use them outside 
of what is already installed on most PCs. And CHM files are typically smaller than any of the other 
outputs. The savings in size alone is one reason that many organizations still rely on CHM files, 
even given the inherent limitations of CHMs.

Guided Activity 10: Generate Microsoft HTML Help
1. Ensure that the completed_project is still open.

2. Generate HTML Help.

 from among the Output Presets, double-click Microsoft HTML Help 

The preset opens for editing.

 select the General category

 in the Title area, change the title to Policies and Procedures

 from the Output Path area, click the Browse icon

 browse to RoboHelp2022Data > output > HTML_Help

 click the Select Folder button

 in the CHM File area, change the name to policies.chm

 close and save the Microsoft HTML Help preset.

 right-click the Microsoft HTML Help preset

 choose Generate
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3. View the Output.

 from among the Output Presets, right-click Microsoft HTML Help

 choose View Output

4. Open the General Office Information book.

5. Spend the next few moments viewing the topics contained within the book.

6. Close the Help window.

7. Right-click the Microsoft HTML Help preset and choose Show in Explorer.

Within the HTML_Help output folder, you’ll find the generated help file: policies.chm. 

Everything the Help System needs to work on a PC user’s computer is contained within 
this one compressed CHM file. 

8. Double-click the CHM file to reopen the generated output.

9. Close the Help Window and return to the RoboHelp project.

10. Close the project.
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