Notice: Although IconLogic makes every effort to ensure the accuracy and quality of these materials, all material is provided without any warranty.

Copyright: 1994-2012 by IconLogic, Inc., 3320 Breckenridge Way, Riva, MD, 21140, 410.956.4949. This document, or any part thereof, may not be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying, recording, storage in an information retrieval system, or otherwise, without the prior written permission of IconLogic.

Trademarks: IconLogic, Inc., and the IconLogic logo are registered trademarks of IconLogic. All companies and product names are trademarks or registered trademarks of their respective companies. They are used in this book in an editorial fashion only. No use of any trade name is intended to convey endorsement or other affiliation with IconLogic books.

Adobe RoboHelp HTML 10: The Essentials
“Skills and Drills” Learning

Kevin A. Siegel
Rank Your Skills

Before starting this book, complete the skills assessment on the back of this page.
### How this assessment works

Below you will find 10 course objectives for *Adobe RoboHelp HTML 10: The Essentials*. **Before starting the book:** Review each objective and rank your skills using the scale next to each objective. A rank of 1 means **No Confidence** in the skill. A rank of 5 means **Total Confidence**. After you’ve completed this assessment, go through the entire book. **After finishing the book:** Review each objective and rank your skills now that you’ve completed the book. Most people see dramatic improvements in the second assessment after completing the lessons.

### Before Starting

<table>
<thead>
<tr>
<th>Objective</th>
<th>Rank</th>
<th>Rank</th>
<th>Rank</th>
<th>Rank</th>
<th>Rank</th>
<th>Rank</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. I can create topics.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>2. I can create books.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>3. I can link topics together.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>4. I can create a Cascading Style Sheet.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>5. I can create Frames.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>6. I can import Captivate SWFs.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>7. I can create a Browse Sequence.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>8. I can create a Custom Window.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>9. I can add Images to a topic.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>10. I can add Dynamic HTML Effects to topics.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
</tbody>
</table>

### Now That I Am Finished

<table>
<thead>
<tr>
<th>Objective</th>
<th>Rank</th>
<th>Rank</th>
<th>Rank</th>
<th>Rank</th>
<th>Rank</th>
<th>Rank</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. I can create topics.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>2. I can create books.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>3. I can link topics together.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>4. I can create a Cascading Style Sheet.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>5. I can create Frames.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>6. I can import Captivate SWFs.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>7. I can create a Browse Sequence.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>8. I can create a Custom Window.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>9. I can add Images to a topic.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>10. I can add Dynamic HTML Effects to topics.</td>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
</tbody>
</table>
## About This Book

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Author</td>
<td>vii</td>
</tr>
<tr>
<td>Book Conventions</td>
<td>viii</td>
</tr>
<tr>
<td>Confidence Checks</td>
<td>viii</td>
</tr>
<tr>
<td>Course Projects</td>
<td>viii</td>
</tr>
<tr>
<td>Student Data Files</td>
<td>ix</td>
</tr>
<tr>
<td>Download Data Files From the IconLogic Data Files Server</td>
<td>ix</td>
</tr>
<tr>
<td>System Requirements</td>
<td>x</td>
</tr>
<tr>
<td>Ordering More Books</td>
<td>x</td>
</tr>
<tr>
<td>Contacting IconLogic</td>
<td>x</td>
</tr>
</tbody>
</table>

## Module 1: Introduction to Adobe RoboHelp

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>RoboHelp's History</td>
<td>2</td>
</tr>
<tr>
<td>Exploring RoboHelp</td>
<td>3</td>
</tr>
<tr>
<td>Open an Existing Project</td>
<td>3</td>
</tr>
<tr>
<td>Pods and Toolbars</td>
<td>5</td>
</tr>
<tr>
<td>Explore the Pods</td>
<td>5</td>
</tr>
<tr>
<td>Workspaces</td>
<td>7</td>
</tr>
<tr>
<td>Create a Workspace</td>
<td>7</td>
</tr>
<tr>
<td>Topics</td>
<td>11</td>
</tr>
<tr>
<td>Create and Edit a Topic</td>
<td>11</td>
</tr>
<tr>
<td>Delete a Topic</td>
<td>12</td>
</tr>
<tr>
<td>Preview a Topic</td>
<td>13</td>
</tr>
<tr>
<td>TOCs and Indexes</td>
<td>14</td>
</tr>
<tr>
<td>Explore a TOC and an Index</td>
<td>14</td>
</tr>
<tr>
<td>Microsoft HTML Help</td>
<td>15</td>
</tr>
<tr>
<td>Generate HTML Help</td>
<td>15</td>
</tr>
<tr>
<td>WebHelp</td>
<td>18</td>
</tr>
<tr>
<td>Generate WebHelp</td>
<td>18</td>
</tr>
<tr>
<td>FlashHelp</td>
<td>21</td>
</tr>
<tr>
<td>Generate FlashHelp</td>
<td>21</td>
</tr>
<tr>
<td>Compliance</td>
<td>22</td>
</tr>
<tr>
<td>Generate Compliant WebHelp</td>
<td>22</td>
</tr>
</tbody>
</table>

## Module 2: New Projects and Adding Content

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating New Projects</td>
<td>26</td>
</tr>
<tr>
<td>Create a Blank Project</td>
<td>26</td>
</tr>
<tr>
<td>Creating Topics</td>
<td>29</td>
</tr>
<tr>
<td>Create a New Topic</td>
<td>29</td>
</tr>
<tr>
<td>Rename and Delete Topics</td>
<td>31</td>
</tr>
<tr>
<td>Importing HTML Files</td>
<td>33</td>
</tr>
<tr>
<td>Import an HTML File</td>
<td>33</td>
</tr>
<tr>
<td>MS Word Content</td>
<td>34</td>
</tr>
<tr>
<td>Import a Word Document</td>
<td>34</td>
</tr>
<tr>
<td>FrameMaker Content</td>
<td>36</td>
</tr>
<tr>
<td>Import an FM File</td>
<td>36</td>
</tr>
<tr>
<td>PDF Content</td>
<td>37</td>
</tr>
<tr>
<td>Import a PDF</td>
<td>37</td>
</tr>
</tbody>
</table>

## Module 3: Project Structure and CSS

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Structure</td>
<td>42</td>
</tr>
<tr>
<td>Create Project Folders</td>
<td>42</td>
</tr>
<tr>
<td>Table of Contents (TOC)</td>
<td>44</td>
</tr>
<tr>
<td>Create a TOC Book</td>
<td>44</td>
</tr>
<tr>
<td>Add Pages to TOC Books</td>
<td>46</td>
</tr>
<tr>
<td>Automatic TOCs</td>
<td>47</td>
</tr>
</tbody>
</table>
Auto-Create a TOC...........................................................................47
Cascading Style Sheets .................................................................48
  Apply a Style Sheet to a Topic ......................................................48
  Apply Paragraph Styles...............................................................51
Custom Style Sheets......................................................................53
  Create a Style Sheet ....................................................................53
Font Sets .......................................................................................57
  Create a Font Set ........................................................................57
Character Styles ...........................................................................59
  Use Inline Formatting ..................................................................59
  Create a Character Style ............................................................61

Module 4: Editing Content
  Spell Check ..................................................................................64
    Use Spell Check ........................................................................64
  AutoCorrect ..................................................................................66
    AutoCorrect Text .......................................................................66
  The Thesaurus ................................................................................67
    Use the Thesaurus ......................................................................67
  Find and Replace Content ............................................................68
    Find and Replace Text ................................................................68
PDF Review ...................................................................................70
  Create a PDF for Review .............................................................70
  Import Comments From a PDF ......................................................74

Module 5: Links
  Linking to Content .......................................................................78
    Link to a Word Document ..........................................................78
    Edit a Linked Word Document ....................................................81
  Hyperlinks .....................................................................................83
    Insert Hyperlinks .......................................................................83
  Bookmarks .....................................................................................87
    Insert Bookmarks .......................................................................87
  Popup Hyperlinks .........................................................................89
    Insert Auto-Sizing Popups ..........................................................89
  Custom-Sized Popups .................................................................94
    Insert Custom-Sized Popups .........................................................94
  Text-Only Popups .........................................................................96
    Insert a Text-Only Popup ............................................................96
Link View ........................................................................................98
  Use Link View .............................................................................98
Broken Links .................................................................................99
  Resolve Broken Links ...................................................................99

Module 6: Images and Multimedia
  Working with Images ....................................................................102
    Insert an Image ........................................................................103
    Add an Image Margin ...............................................................106
Background Images .......................................................................108
  Add a Background Image .............................................................108
Image Maps ...................................................................................111
  Add Hotspots to a Graphic ..........................................................111
eLearning Integration .....................................................................114
  Insert an Adobe Captivate Demo ................................................114
Dynamic HTML .............................................................................116
  Create a Drop-Down Hotspot ......................................................116
<table>
<thead>
<tr>
<th>Module 7: Build Tags, Variables and Snippets</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Build Tags</td>
<td>122</td>
</tr>
<tr>
<td>Create a Conditional Build Tag</td>
<td>122</td>
</tr>
<tr>
<td>Apply a Conditional Build Tag</td>
<td>124</td>
</tr>
<tr>
<td>Create a Build Tag Expression</td>
<td>126</td>
</tr>
<tr>
<td>Content Categories</td>
<td>130</td>
</tr>
<tr>
<td>Create a New TOC</td>
<td>130</td>
</tr>
<tr>
<td>Apply Topic-Level Tags</td>
<td>133</td>
</tr>
<tr>
<td>Create Content Categories</td>
<td>134</td>
</tr>
<tr>
<td>User Defined Variables</td>
<td>137</td>
</tr>
<tr>
<td>Work With Variables</td>
<td>137</td>
</tr>
<tr>
<td>Snippets</td>
<td>140</td>
</tr>
<tr>
<td>Work With Snippets</td>
<td>140</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Module 8: Tables &amp; Lists</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Working With Tables</td>
<td>144</td>
</tr>
<tr>
<td>Insert a Table</td>
<td>144</td>
</tr>
<tr>
<td>Insert a Table Row</td>
<td>147</td>
</tr>
<tr>
<td>Work With Table Styles</td>
<td>148</td>
</tr>
<tr>
<td>Change Table Properties</td>
<td>152</td>
</tr>
<tr>
<td>Lines, Symbols and Lists</td>
<td>156</td>
</tr>
<tr>
<td>Add a Horizontal Line</td>
<td>156</td>
</tr>
<tr>
<td>Insert a Symbol</td>
<td>157</td>
</tr>
<tr>
<td>Add a Bulleted List</td>
<td>158</td>
</tr>
<tr>
<td>Create a List Style</td>
<td>161</td>
</tr>
<tr>
<td>Edit a List Style</td>
<td>163</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Module 9: Indexes, Search and Glossaries</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Indexes</td>
<td>168</td>
</tr>
<tr>
<td>Run the Smart Index Wizard</td>
<td>168</td>
</tr>
<tr>
<td>Remove and Add Index Entries</td>
<td>172</td>
</tr>
<tr>
<td>Add Keywords via Topic Properties</td>
<td>173</td>
</tr>
<tr>
<td>Subkeywords</td>
<td>175</td>
</tr>
<tr>
<td>Add Subkeywords to the Index</td>
<td>175</td>
</tr>
<tr>
<td>Relating Topics</td>
<td>177</td>
</tr>
<tr>
<td>Create a See Also Keyword</td>
<td>177</td>
</tr>
<tr>
<td>Insert a Link Control</td>
<td>178</td>
</tr>
<tr>
<td>Search</td>
<td>181</td>
</tr>
<tr>
<td>Add Custom Search Terms</td>
<td>181</td>
</tr>
<tr>
<td>External Content Search</td>
<td>183</td>
</tr>
<tr>
<td>Create External Search</td>
<td>183</td>
</tr>
<tr>
<td>Glossaries</td>
<td>186</td>
</tr>
<tr>
<td>Add Glossary Terms</td>
<td>186</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Module 10: Skins and Master Pages</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Skins</td>
<td>190</td>
</tr>
<tr>
<td>Create a New Skin</td>
<td>190</td>
</tr>
<tr>
<td>Customize a WebHelp Skin</td>
<td>194</td>
</tr>
<tr>
<td>Customize the Search Highlight Color</td>
<td>197</td>
</tr>
<tr>
<td>Master Pages</td>
<td>198</td>
</tr>
<tr>
<td>Create a Master Page</td>
<td>198</td>
</tr>
<tr>
<td>Edit a Master Page</td>
<td>202</td>
</tr>
<tr>
<td>Breadcrumbs</td>
<td>203</td>
</tr>
<tr>
<td>Add Breadcrumbs to a Master Page</td>
<td>203</td>
</tr>
</tbody>
</table>
# Contents

| Topic TOCs | 205 |
| Add a Topic TOC | 205 |

## Module 11: Windows, Browsing and CSH
- Custom Windows | 210 |
- Create a Custom Window | 210 |
- Browse Sequences | 215 |
- Create a Browse Sequence | 215 |
- Application Help | 217 |
- Test an API Call for Help | 217 |
- Publishing | 219 |
- Publish a Layout | 219 |
- Context Sensitive Help | 224 |
- Review CSH Source Code | 224 |
- Create a WebHelp Window | 226 |
- Assign Map IDs | 227 |

## Module 12: Docs, eBooks and Scripts
- Printed Docs | 232 |
- Enable Word Macros | 232 |
- Generate a Print Doc | 233 |
- eBooks | 237 |
- Create an eBook | 237 |
- Reports | 241 |
- Generate a Report | 241 |
- Scripts | 243 |
- Run a Script | 243 |
- Edit a Script | 244 |

## Module 13: Adobe AIR and Multiscreen HTML5
- Adobe AIR | 248 |
- Create Browser Based AIR Help | 248 |
- Create AIR Application Help | 251 |
- Multiscreen HTML5 | 254 |
- Generate HTML5 | 254 |

## Module 14: Forms and Frames
- Forms | 258 |
- Create a New Topic | 258 |
- Insert a Form and Form Element | 259 |
- Add Radio Buttons | 260 |
- HTML Editing | 263 |
- Add HTML Code to a Topic | 263 |
- Check Boxes and Menus | 265 |
- Add a Check Box | 265 |
- Insert a Drop-Down Menu | 266 |
- Add a Multi-line Text Field | 268 |
- Submit and Reset Buttons | 269 |
- Add Submit and Reset Buttons | 269 |
- Form Properties | 270 |
- Name a Form and Set an Action | 270 |
- Frames | 271 |
- Import HTML Files | 271 |
- Create a Frameset | 273 |
- Modify Frameset Attributes | 277 |
- Link Topics Into Frameset Regions | 279 |
About This Book

This Section Contains Information About:

- The Author, page vii
- Book Conventions, page viii
- Course Projects, page viii
- Student Data Files, page ix
- System Requirements, page x
- Contacting IconLogic, page x

The Author


Kevin spent five years in the U.S. Coast Guard as an award-winning photojournalist and has more than two decades experience as a print publisher, technical writer, instructional designer and eLearning developer. He is a certified technical trainer, has been a classroom instructor for more than 20 years and is a frequent speaker at trade shows and conventions.

Kevin holds multiple certifications from companies such as Adobe and the CompTIA. You can reach Kevin at ksiegel@iconlogic.com.
Book Conventions

I believe that learners learn by doing. With that simple concept in mind, IconLogic books are created by trainers/authors with years of experience training adult learners. Before IconLogic books, our instructors rarely found a book that was perfect for a classroom setting. If the book was beautiful, odds were that the text was too small to read and hard to follow. If the text in a book was the right size, the quality of exercises left something to be desired.

Finally tiring of using inadequate materials, our instructors started teaching without any books at all. Years ago we had many students ask if the in-class instruction came from a book. If so, they said they’d buy the book. That sparked an idea. We asked students—just like you—what they wanted in a training manual. You responded, and the methodology is used in this book and every IconLogic training manual.

This particular book has been divided into several modules. Since each module builds on lessons learned in a previous module, I recommend that you complete each module in succession. During every module, you will be guided through lessons step by step. Instructions for you to follow will look like this:

☐ instructions for you to follow will look like this

If you are expected to type anything or if something is important, it will be set in bold type like this:

☐ type 9 into the text field

When you are asked to press a key on your keyboard, the instruction will look like this:

☐ press [shift]

I hope you enjoy the book. If you have any comments or questions, please see the end of this section for our contact information.

Confidence Checks

As you move through the lessons in this book, you will come across the little guy at the right. He indicates a Confidence Check. Throughout each module you will be guided through hands-on, step-by-step exercises. But at some point you’ll have to fend for yourself. That is where Confidence Checks come in. Please be sure to complete each of the challenges because some exercises build on completed Confidence Checks.

Course Projects

During the activities that appear in this book, pretend that you are the technical communicator for a fictional company called Super Simplistic Solutions. As a technical communicator, it is your job to create all of the documentation for the company’s products, services and internal processes. During the lessons presented in this book, you will be using Adobe RoboHelp HTML 10 to create a Policies and Procedures guide that might be accessed by users on a Windows-based computer, an Apple computer, a laptop or even a mobile device (such as an iPad or iPhone). This book will teach you how to create the policies guide, and it will teach you how to
deliver the generated output files (called Layouts) for consumption on just about any device. Although the information you create in the policies guide is fictional, the content will likely seem similar to information found in just about any procedures guide. Nevertheless, none of the information presented in the guide is based on real people or companies. Any similarities are purely coincidental.

Student Data Files

The data files necessary to complete the student activities in this book are available for download via our website. You will be walked through the steps necessary to download the files during the following activity.

Student Activity: Download Data Files From the IconLogic Data Files Server

1. Download the data files necessary to complete the lessons presented in this book.
   - start your web browser and go to the following web address: http://iconlogic.com/pc.htm
   - click the RoboHelp HTML 10, Essentials of link and Save the file to your desktop

   The zipped data files should be downloaded to your desktop as an EXE file.

2. After the file has fully downloaded, close the web browser.

3. Extract the data files.
   - find the RoboHelp10Data.exe file you just downloaded to your desktop
   - double-click the file to open it (it’s an EXE file containing the zipped data files)
   - click Run or Yes if presented with a Security Warning dialog box
   - confirm C:\ appears in the Unzip to folder area
   - click the Unzip button
   - when the extraction is complete, click the OK button and then click the Close button  

Several thousand files will be unzipped into a folder called RoboHelp10Data (I believe the total count was right around 7500). I know, that’s a lot of files. No worries. There are 14 projects within RoboHelp10Data. Although RoboHelp projects can result in a large number of files, the vast majority are tiny. The total size of the assets included in the RoboHelp10Data folder is around 150 MB.

As you move through the lessons in this book, you will be opening files from and saving to the RoboHelp10Data folder. When you have completed the lessons in this book, you can delete both the RoboHelp10Data folder and the RoboHelp10Data.exe file you downloaded.
System Requirements

To complete the lessons in this book, you will need the following software:

- Adobe RoboHelp version 10 (RoboHelp does not come with this book. You can order the software directly from Adobe. If you don’t want to buy the software, the trial version of software, which you can download from Adobe’s website, works great.)
- Microsoft Word (Word 2010 is shown in this book, but older versions will work just fine. If you have a newer version of Word than 2010, such of Word 2013, all bets are off. You’ll need to check with Adobe and see if you’ll be okay using something newer.).

According to Adobe, here is the minimum system requirements to install and use RoboHelp 10:

- Intel Pentium 4
- Microsoft Windows 7, Windows Vista with Service Pack 2 or Windows XP with Service Pack 3
- 1GB of RAM
- 3.1GB of available hard-disk space for installation

Ordering More Books

We are proud to offer books on the following subjects:

Editing and Grammar


Editing With MS Word 2007

eLearning

Adobe Captivate versions 4 through 6

Techsmith Camtasia Studio versions 6 through 8

Help Authoring

Adobe RoboHelp versions 6 through 10

Contacting IconLogic

IconLogic, Inc.
3320 Breckenridge Way | Riva, MD 21140 | 410.956.4949
Web: www.iconlogic.com | Email: info@iconlogic.com
Module 1: Introduction to Adobe RoboHelp

In This Module You Will Learn About:

- RoboHelp’s History, page 2
- Exploring RoboHelp, page 3
- Pods and Toolbars, page 5
- Workspaces, page 7
- Topics, page 11
- TOCs and Indexes, page 14
- Microsoft HTML Help, page 15
- WebHelp, page 18
- FlashHelp, page 21
- Compliance, page 22

And You Will Learn To:

- Open an Existing Project, page 3
- Explore the Pods, page 5
- Create a Workspace, page 7
- Create and Edit a Topic, page 11
- Delete a Topic, page 12
- Preview a Topic, page 13
- Explore a TOC and an Index, page 14
- Generate HTML Help, page 15
- Generate WebHelp, page 18
- Generate FlashHelp, page 21
- Generate Compliant WebHelp, page 22
RoboHelp’s History

What is RoboHelp? Where did it come from? And what can you do with RoboHelp? According to Adobe, "RoboHelp is an easy-to-use authoring and publishing solution." Adobe also says that RoboHelp will allow you to "deliver content to the iPad and other tablets, smartphones, and desktops using output formats such as multi-screen HTML5, WebHelp, CHM, Adobe AIR Help, PDF, eBook, and native mobile apps.” Everything Adobe says about RoboHelp is true, and you’ll see that for yourself as you work and learn RoboHelp via the lessons presented in this book.

I started using RoboHelp when it was owned by a company called Blue Sky Software. That company re-branded itself as eHelp Corporation. Later, eHelp was absorbed by Macromedia, which was, in turn, gobbled up by Adobe. There have been 18 versions of RoboHelp over the years. You might be wondering why this version of RoboHelp isn't named RoboHelp 18. Over the years, RoboHelp version numbers have included names like RoboHelp 5, 6, 7, 2002, X3, X4 and X5. When Adobe took over RoboHelp, Adobe elected to use numbers as versions. RoboHelp 6 was Adobe’s first RoboHelp. However, eHelp Corporation also had a RoboHelp version 6. Yes, that’s right. There was once eHelp RoboHelp 6, and there was also an Adobe RoboHelp version 6, creating a bit of confusion early on. Thankfully, RoboHelp 10 is the one and only, in more ways than one.

What’s in a Name?

When RoboHelp was installed on your computer, you had the option to install two different programs named RoboHelp: RoboHelp 10 for Word and RoboHelp 10 HTML. Both programs use RoboHelp to author Help content, but they go about it very differently. RoboHelp for Word uses RoboHelp and Microsoft Word to author content. I used RoboHelp for Word years ago, but never really cared much for it. Everything worked, but since two programs were involved in the process (Word and RoboHelp), there always seemed to be one issue or another (crashes, performance problems, etc). So, as a result of experience, this book focuses exclusively on RoboHelp 10 HTML.

With RoboHelp HTML, all of the authoring occurs within RoboHelp. While you can import Word content into a RoboHelp HTML project (you will learn how later), Word isn’t running while authoring. As a user of RoboHelp HTML over the years, I’ve found the development process significantly smoother than what I experienced with RoboHelp for Word. I’m not saying you won’t experience crashes, but RoboHelp crashes far less than other programs I’ve used.

Because RoboHelp HTML has the letters HTML in its name, many people think that RoboHelp HTML is a web authoring tool (much like Adobe Dreamweaver)—it is not. Although you can create websites using RoboHelp HTML, its primary mission is to let you quickly and easily create Help systems. While Robo is a strange start to the name, it fits since you’ll be creating some pretty complex stuff without doing any of the heavy lifting. HTML is a simple formatting language. You put codes (markups) inside text files so that they can be read by web browsing software. While RoboHelp uses programming code to create Help content, there is zero requirement on your part to know any coding language.

Note: I’ve mentioned the term “Help system” a few times already. A Help system provides information to a user via a computer or mobile device. While most Help systems are designed to give assistance on a particular software application or operating system, Help systems can be used to present information on just about anything, such as corporate policies and procedures guide or how to tie the perfect knot.
Exploring RoboHelp

During the lessons that follow, I’m going to have you open an existing RoboHelp project, explore a bit and then generate content. As you move through subsequent modules in this book, you will learn how to create this project from scratch.

**Note:** If you have not already downloaded the RoboHelp10Data student data files to your hard drive, see page ix (in the first section of this book).

**Student Activity: Open an Existing Project**


   The RoboHelp 10 software is not included with this book. If you do not have RoboHelp, you can purchase the tool or download the trial software from Adobe (www.adobe.com).

   After starting the RoboHelp application, the first thing you will see is the RoboHelp HTML Starter. From here you can open existing projects (via the Recent Project area), create new projects (via the Create New area), import assets and find additional resources.

2. Open an existing project from the RoboHelp10Data folder.
   - from the top of the RoboHelp Starter, choose **File > Open**
   - navigate to the **RoboHelp10Data** folder

   The RoboHelp10Data folder contains all kinds of assets that support the lessons in this book. You will find images, importable content and existing projects. You’ll be instructed on how and when to use these assets as you move through the lessons in this book.

   - open the **RoboHelpProjects** folder
   - open the **FinishedHelpSystem** folder

   There are several subfolders within the FinishedHelpSystem folder. Cumulatively, all of the assets within those folders support the main RoboHelp project file (the project file’s name is **finished.xpj**).

   - open **finished.xpj**
During the lessons presented throughout this book, you will learn how to re-create this project from scratch. From a scenario standpoint, you now work for a mythical company called **Super Simplistic Solutions**. You have been hired to create, among other things, the corporate policies and procedures guide. Rather than create the guide in a traditional word processor or desktop publishing application, you are going to create the guide using RoboHelp.

Before moving forward, I’d like to further explain the RoboHelp project file: the xpj file. The xpj file is usually quite small. Nevertheless, the project file has a massive job. It controls the structure of the entire project (the project’s folder structure, the TOC’s, the Indexes, etc). While the xpj file does not contain the Help system’s content, it does keep track of where the content is stored, manages links, images and a bunch of other behind the scenes functions.
Pods and Toolbars

There are 10 toolbars in RoboHelp, and you can make more. There are more than a dozen pods. Some of the pods are open now... they’re the boxes you see that contain all manner of stuff. Now that you have opened an existing project, it’s a good bet that you are visually overwhelmed by all of those pods and toolbars. During the next few activities, you’ll begin to learn your way around. What looks like chaos now will soon make sense.

Student Activity: Explore the Pods

1. View a Pod.
   - choose View > Pods > Snippets

   The Snippets pod usually opens in the upper left of the RoboHelp window, just below the menu bar and the toolbars. You will learn to create and work with Snippets beginning on page 140.

2. Close Pods.
   - at the top of the Snippets pod, right-click the word Snippets
   - choose Close
3. Explore the Project Manager pod.
   - choose **View > Pods > Project Manager**

   By default, the Project Manager pod appears where you last saw the Snippets pod... in the upper left of the RoboHelp window. You can use the Project Manager to edit, delete and create topics and folders, as well as manage other assets.

4. Expand and collapse the folders in the Project Manager pod.
   - click anywhere within the **Project Manager** pod
   - from the main RoboHelp menu, choose **View > Expand All**

   All of the folders within the Project Manager pod expand. Explore the contents that had been hiding within the collapsed folders.

   - from the main RoboHelp menu, choose **View > Collapse All**

5. De-clutter the RoboHelp interface.

   - close each of the pods and windows currently on the screen by clicking the X at the top right of each window (or you can right-click the name of each pod and choose Close).

   With everything closed, except RoboHelp, your window should look like this:
Workspaces

Because there are so many pods available within RoboHelp, you might appreciate the ability to create multiple Workspaces (environments) within RoboHelp. For instance, if you find yourself working on the Snippets pod most of the day, you can create a Workspace where the Snippets pod always appears in a specific location on your display and is possibly grouped with other pods you use frequently.

Student Activity: Create a Workspace

1. Ensure that all of the pods and windows within RoboHelp have been closed.

2. View and position the Snippets pod.
   - choose View > Pods > Snippets
   - click and hold on the word “Snippets” and then drag the Snippets pod to the middle of the RoboHelp window
   
   As you drag a pod, you’ll see arrows appear on your display (as shown in the picture below). Those arrows will disappear when you stop dragging.

3. View and position the Project Set-up pod.
   - choose View > Pods > Project Set-up
   - click and hold on the words “Project Set-up” and drag the Project Set-up pod just to the left of the Snippets pod
   - position and resize the pods until your RoboHelp window looks similar to the picture below
4. Save the Workspace.
   - from the upper-right of the RoboHelp window, click the **Workspace** menu and choose **Save**

   ![Workspace Menu]

   The Save As dialog box appears.
   - navigate to **C:\RoboHelp10Data**
   - change the File name to **Snippets_ProjectSetup**
   - click the **Save** button

   The Workspace has been saved with an **RHS** extension.

5. Load the default Workspace.
   - from the upper-right of the RoboHelp window, click the **Workspace** menu and choose **Default**

   The RoboHelp Workspace returns to its default appearance.

6. Load a saved Workspace.
   - from the upper-right of the RoboHelp window, click the **Workspace** menu and choose **Load**

   The Open dialog box appears.
   - open the **Snippets_ProjectSetup.rhs** Workspace you created a moment ago (you should have saved the Workspace file to the RoboHelp10Data folder)

   Both the Snippets and Project Set-up pods should reappear in the exact location specified when you created the Workspace.

7. Load the default Workspace.
   - from the Workspace menu, choose **Default**

   The RoboHelp window once again returns to its default appearance.
Confidence Check

1. Choose **Tools > Options**.
   
The Options dialog box will open. There are five groups of Settings along the left side of the dialog box.

2. From the **Settings** area at the left, select the **General** group and ensure your options match the picture below.

![General Settings](image)

The settings in the image above are the application default. You will learn the value of many of these settings as you move through the book. For now, it’s enough to ensure the settings here are set to the default.

3. Select the **Recent Projects** group.

   You can remove projects that appear in the RoboHelp Starter when you first start RoboHelp.

![Recent Projects](image)

If you’d like, you can remove any of the recent projects in the list by clicking the **Remove** button. (Removing projects from the list will not affect the lessons in this book, or RoboHelp’s performance.)
4. Select the **File Association** group.
5. In the HTML Editors area, select **Design View**
6. Click the **Set As Default** button.
7. If necessary, click the **Use Default Editor** radio button at the bottom of the dialog box.

You will soon be importing content into a RoboHelp project from Microsoft Word and other sources (during lessons beginning on page 33). By selecting **Use Default Editor**, content that you attempt to edit with RoboHelp will always open in RoboHelp’s Design Window instead of in the program used to create the content.

8. Click the **OK** button to close the Options dialog box.

**Note:** The changes you have just made while in the Options dialog box will not have an obvious effect in the current RoboHelp project.

9. Go to the Workspace menu and choose **Load**.
10. Open the **NoClutter.rhs** from the **RoboHelp10Data** folder.

While working with any particular Workspace is optional, I’ve created the NoClutter workspace for you to ensure that the most commonly used pods are at your fingertips, and the lesser-used pods are hidden away. You’ll be frequently reminded to load the NoClutter Workspace as you move through this book. Feel free to ignore that request if you’d prefer to use your own Workspace (or the Default workspace).
Topics

You’ve likely heard the saying that “Content is King.” It’s true. The heart of any Help system is its content. When you create content within RoboHelp, that content is known as a topic. Topics typically consist of text formatted with styles (styles are covered on page 48), images (page 102), hyperlinks (page 83) and more. The project you’ve opened has all of the topic elements named above. In the next few activities, you’ll create a topic, edit a bit and then delete it.

Student Activity: Create and Edit a Topic

1. Ensure that the finished project is still open.

2. Create a new topic.
   - choose File > New > Topic
     
     The New Topic dialog box opens.

     - on the General tab, change the Topic Title to My First Topic
     - from the Master Page drop-down menu, choose (None)

     You were asked to choose (None) as the Master Page so that no elements from the existing Master Page appear on the topic. You will learn how to create Master Pages and how to use them on page 198.

     - click the OK button

     Your new topic opens in the Design Window.

3. Edit the new topic.
   - replace the words “Type topic text here” with The best Help topic will contain only enough text to get my point across and no more. One paragraph or two is ideal, supported by an image or two.
Student Activity: Delete a Topic

1. Ensure that the finished project is still open.

2. Delete a topic.
   - locate the Topic List pod (if you’re using the Default Workspace, the Topic List pod is at the bottom of the RoboHelp window)
   - on the Topic List pod, scroll down the list until you see the My First Topic topic
   - right-click the My First Topic topic and choose Delete

You will be asked to confirm the action.

- click the Yes button
Student Activity: Preview a Topic

1. Ensure that the **finished** project is still open.

2. Open an existing topic.
   - On the **Topic List** pod, locate and open **The Learning Center**

   This topic has been formatted using Dynamic HTML. The main heading has been set to fade in when viewed through a web browser. The three subheads will reveal an interactive eLearning video when viewed through a web browser. The problem is you can’t enjoy any of the effects because the Design View isn’t a web browser. No worries... if you want to get a better idea of how a topic will behave when viewed through a browser, you can **Preview**.

3. Preview the topic.
   - Click anywhere within the open Learning Center topic
   - Choose **View > View Item**

   The main heading automatically fades in. You’ll learn to add this effect on page 118.

4. Start an eLearning video.
   - Click any of the three subheads within the preview

   An eLearning lesson magically appears beneath each subhead. And the lessons are totally interactive (go ahead and click within each lesson when prompted). How cool is that? You will learn how to integrate eLearning with a RoboHelp project beginning on page 114.

5. When finished exploring the preview, close the preview.
TOCs and Indexes

When users access your Help system, they'll typically rely on a Table of Contents (TOC) to understand the structure or logic behind the Help system. Users will rely on an Index to quickly find content (just as you might do when reading a reference guide). The finished project already has both a TOC and an Index. You will learn how to create both during lessons presented later in this book.

Student Activity: Explore a TOC and an Index

1. Ensure that the finished project is still open.

2. Open an existing TOC.
   - on the Project Manager pod, open the Table of Content folder
   - This project contains three TOCs.
   - double-click SSS_East to open the TOC
     
     ![SSS_East - Table Of Contents](image)

You will learn to create this TOC beginning on page 130.

3. Open an existing Index.
   - on the Project Manager pod, open the Index folder
   - double-click policies (Default) to open the Index
     
     ![policies (Default) - Index](image)

You will learn to create this Index beginning on page 168.
Microsoft HTML Help

If you’d like to get a sense of what your users will experience when accessing your Help System, you need to get RoboHelp to churn out content that your users can access. Those users will NOT own RoboHelp. The process of instructing RoboHelp to churn out usable content is known as Generating.

The Single Source Layouts pod, located in the lower left of the RoboHelp window, contains several layouts by default. Arguably, the most popular Single Source Layouts today are WebHelp, FlashHelp and Microsoft HTML Help. However, I would expect that Multiscreen HTML5, which is new in RoboHelp 10, will one day ascend to the top spot. However, Multiscreen HTML5 is new and will need time to gain fans. I’ll cover the ins and outs of Multiscreen HTML 5 layouts later. As you move through the remaining lessons in this module, you will generate Microsoft HTML Help, WebHelp and then FlashHelp.

Microsoft HTML Help (HTML Help for short) is the oldest of the layouts. When you generate HTML Help, RoboHelp creates a single, compressed CHM file (pronounced “chum”). A CHM file works great if your users are accessing the Help system with a Windows-based PC and if the CHM file has been installed on the users hard drive. CHM files will not work if your users are accessing the Help system with a Macintosh computer, or a mobile device. CHM files won’t work well if users open them via the internet or an intranet. Nor do they perform well if accessed from a server. Last, but not least, you are limited by how much you can customize the look and feel of the generated HTML Help window.

Given all the negative stuff I just wrote above, you might think that HTML Help is a layout that is best avoided. Not necessarily. There is much to like about this output. For instance, HTML Help files are self-contained Help Systems (you don’t need other programs to use them outside of what is already installed on most Windows-based computers). And CHM files are typically much, much smaller than any of the other layouts. The savings in size alone is one reason that many people rely on CHM files, even given their inherent limitations.

Student Activity: Generate HTML Help

1. Generate the Microsoft HTML Help Layout.
   - **on the Single Source Layouts pod (in the lower left of the RoboHelp window), double-click Microsoft HTML Help**

   The HTML Help Options dialog box opens. There are several options available. For now, you’ll leave the options set to the default.

   - **click the Save and Generate button**

   Since the project is small, generating the layout takes only seconds. As the project is generated, it is also compressed.
2. View the generated layout.
   
   ❑ click the **View Result** button

The generated layout opens in the Microsoft Windows Help viewer. The Help Viewer is installed on all PCs running Windows. What you see is exactly what your users will see.
Confidence Check

1. Notice that the TOC in the CHM file is the same TOC you explored a moment ago within RoboHelp.

2. Open the General Office Information book.

3. Spend the next few moments selecting the pages you find inside the book.

4. Select the Index tab and notice that this is the same Index that you explored in RoboHelp a moment ago.


7. Open the RoboHelpProjects folder and then open the FinishedHelpSystem folder.

8. Open the !SSL! folder (SSL stands for Single Source Layout), and then open the Microsoft.HTML.Help folder.

   Within the Microsoft.HTML.Help folder you’ll find the generated HTML Help file. Everything the Help System needs to work on your users computer is included in this one highly compressed CHM file.

9. Double-click the chm file to open the generated Help system.

10. Close all of the windows and return to the RoboHelp project.

   **Note:** Keep the following in mind if you elect to go with HTML Help as your layout of choice. First, HTML Help files (the CHM file) run only on PCs that use Microsoft Windows. Consumers who use Macs, Linux or Unix-based computers cannot open an HTML Help file. Second, HTML Help relies on Internet Explorer. Internet Explorer does not need to be the default browser, and it never needs to run when the user uses the HTML Help file, but it must be on the user’s PC. Third, the HTML Help file works reliably only if it is installed locally on each user’s hard drive.
WebHelp

You generated Microsoft HTML Help during the last few activities. While Microsoft HTML Help results in the fewest and smallest output files to manage (the single CHM file), CHM files are limited in many ways (see page 15).

As an alternative to HTML Help, WebHelp is a great layout choice for producing cross-browser, cross-platform Help systems that will work on just about any computer. WebHelp works great when posted to a web server, eliminating the need to install a CHM file on every user’s computer. And you will learn later in this book that WebHelp is very customizable via a Skin Editor (page 190). Perhaps the only downside to WebHelp is the sheer number of files that will get generated. Remember that Microsoft HTML Help results in a single CHM file. When you generate WebHelp, you could potentially be generating thousands of co-dependent files that must always be kept together on a web server to ensure that the Help system works as expected.

Student Activity: Generate WebHelp

1. Ensure that the finished project is still open.

   By setting WebHelp as the Primary Layout, you’ll be able to use a specific keyboard shortcut to quickly generate the layout.

2. Generate WebHelp.

   - on the Single Source Layouts pod, right-click WebHelp (Primary Layout) and choose Generate

   The WebHelp Settings dialog box opens.

   - in the Title Bar area, replace the existing text with Super Simplistic Solutions

   The text you just typed will appear in the web browser’s Title Bar.

   - click the Save and Generate button

   As with HTML Help, once the layout is generated you will be asked if you would like to view the output.

   - click the View Result button

   The Help System opens within your computer’s default web browser. On my computer, I routinely use Chrome, Internet Explorer, FireFox and Safari. I’ve tested my Help System using all of the browsers and have been mostly satisfied with the results. I would encourage you to install any web browser your consumer is likely to use and test your Help System in each. Below is how the Help system looked through Mozilla Firefox.
Notice that the Navigation area at the top of the window (Contents, Index, etc.) is very graphical. I saw the same thing when I used Google Chrome. However, when I previewed the Help system in Internet Explorer, the results weren’t very good. As shown below, the images in the Navigation area are missing, and I received a warning about ActiveX controls. If Internet Explorer is your default web browser, I’m betting your Help System looked very much like the picture below.

3. Close the browser window.

Some web browsers block certain content from being viewed locally. In the image above, Internet Explorer blocked my ActiveX controls, which is preventing parts of the Help System from loading into the browser window. The blocked content would appear just fine if the Help System was opened from within a web server. But since you and I are working locally, it’s likely
that you are not currently viewing a fully functioning version of the Help System. You can allow RoboHelp to bypass the browser blocks by enabling a feature known as **Mark of the Web.** Basically, Mark of the Web will allow you, as a Help Author, to bypass the blocked content so you can accurately test your Help system.

4. Enable Mark of the Web.
   - close the browser window and return to RoboHelp
   - on the Single Source Layouts pod, right-click **WebHelp (Primary Layout)** and choose **Properties**

   The WebHelp Settings dialog box re-opens.
   - select **Navigation** from the list of options at the left of the dialog box
   - select **Add Mark of the Web**

   ![Image](image.png)

   - click the **Save** button

5. View the Help System with a specific web browser.
   - on the Single Source Layouts pod, right-click WebHelp (Primary Layout) and choose **View With** and then select **Internet Explorer**

   ![Image](image.png)

   - click **Yes** when prompted to compile the layout before running

   Thanks to Add Mark of the Web, the images now appear in the Navigation area. (You may still see alerts about ActiveX controls, but those errors can be ignored. You’re getting those messages because you are still testing web content locally, which can always lead to blocked content.)

6. Close the browser window and return to RoboHelp.
FlashHelp

FlashHelp takes the concept of WebHelp to another level by employing the prowess of Flash to provide visually stunning Help systems. FlashHelp layouts will display correctly across most browsers and platforms, and Help components (such as toolbars, the TOC, the Index and Search) can be animated.

There are two primary limitations of using FlashHelp as your layout of choice. First, your users will need the free Adobe Flash Player and a web browser to consume your content. If users do not have the Flash Player, they will see only a blank screen when accessing the Help system. For that reason alone, FlashHelp isn’t widely used as a standard output format. Second, customization is difficult. As you will learn later in this book, customizing WebHelp is easy thanks to a Skin Editor that is included within RoboHelp. If you’d like to customize FlashHelp, you will need Adobe Flash, which isn’t a program that most Help authors own, or know how to use.

Student Activity: Generate FlashHelp

1. Ensure that the finished project is still open.

2. Set up FlashHelp.
   - on the Single Source Layouts pod, double-click FlashHelp to open the FlashHelp options
   - in the Title Bar area, replace the existing text with Super Simplistic Solutions
   - at the bottom of the dialog box, select Add Mark of the Web and then click the Save button

3. View FlashHelp with Internet Explorer.
   - on the Single Source Layouts pod, right-click FlashHelp and choose View With > Internet Explorer (when prompted, click Yes to Generate)

When the FlashHelp layout is opened by the browser, notice that there are Flash animations as the folders and topics flew onto the TOC.

4. Explore the FlashHelp layout. When finished, close the browser window and return to the RoboHelp project.
Compliance

If you work for the US federal government, your Help system will likely need to be Section 508 compliant. Simply put, Section 508 is part of the US Rehabilitation Act of 1973 and requires that many things that are accessible to the general public also must be accessible to people with disabilities.

You can create 508 Compliant layouts if you elect to use WebHelp. Although many of WebHelp’s fancy bells and whistles are not 508 Compliant, RoboHelp can be set up for compliance. You should visit www.section508.gov and familiarize yourself with the 508 Compliance rules, see if you are required to generate compliant content and, if so, ensure that all of your Help system is compliant.

W3C Compliance

Web browsers try to display web pages even if the code used to create them is not acceptable HTML. When a browser comes across HTML it does not understand, the browser interprets the code the best it can. The problem is that browsers interpret questionable code differently. Some browsers show problematic HTML as gibberish, while others crash.

You can ensure that your Help topics are World Wide Web Consortium (W3C) compliant—meaning that the HTML used in your topics adheres to standards established by the W3C—by selecting W3C Compliance when you generate WebHelp. To learn more about W3C compliance and the W3C, visit www.w3.org.

Student Activity: Generate Compliant WebHelp

1. Duplicate a layout.
   - on the Single Source Layouts pod, right-click WebHelp (Primary Layout) and choose Duplicate Layout
   - change the Layout name to Accessible_WebHelp
   - click the OK button

2. Generate a layout that is both 508 and W3C compliant.
   - on the Single Source Layouts pod, double-click the Accessible_WebHelp layout to open the WebHelp Settings dialog box
   - from the Navigation group, select W3C Compliant Topics
   - from the same area, select Section 508 Compliant Output
☐ click the **Save and Generate** button
☐ click the **View Result** button

The compliant layout is not as graphical as the previous WebHelp layouts you’ve seen. Notice that the TOC in this version of your Help system is open by default to make navigation easier to someone who will be using a keyboard to navigate.

While many parts of this layout would now pass compliance testing, there is much more you would need to do to the topics to make this Help system fully compliant. For instance, you would have to ensure that all hyperlinks and images have ALT text. You’ll be working with ALT text later.

3. Close the web browser.
4. Return to RoboHelp.
5. Save and then close the finished project.