Rank Your Skills

Before starting this book, complete the skills assessment on the back of this page.
## Skills Assessment

**How this assessment works**
Below you will find 10 course objectives for "Essentials of Adobe RoboHelp 8 HTML." **Before starting the book:** Review each objective and rank your skills using the scale next to each objective. A rank of 1 means **No Confidence** in the skill. A rank of 5 means **Total Confidence**. After you've completed this assessment, go through the entire book. **After finishing the book:** Review each objective and rank your skills now that you've completed the book. Most people see dramatic improvements in the second assessment after completing the lessons.

### Before Starting
1. I can create topics.  
2. I can create books.  
3. I can link topics together.  
4. I can create a Cascading Style Sheet.  
5. I can create Frames.  
6. I can import Captivate SWFs.  
7. I can create a Browse Sequence.  
8. I can create a Custom Window.  
9. I can add Images to a topic.  
10. I can add Dynamic HTML Effects to topics.

### Now That I Am Finished
1. I can create topics.  
2. I can create books.  
3. I can link topics together.  
4. I can create a Cascading Style Sheet.  
5. I can create Frames.  
6. I can import Captivate SWFs.  
7. I can create a Browse Sequence.  
8. I can create a Custom Window.  
9. I can add Images to a topic.  
10. I can add Dynamic HTML Effects to topics.
Contents
# About This Book

- About the Author: vii
- About IconLogic Books: vii
- Book Conventions: viii
- Confidence Checks: viii
- Student Data Files: ix
- Download Data Files From the IconLogic Data Files Server: ix
- Software and System Requirements: ix
- Need More Books?: x

## Module 1: Introduction to RoboHelp

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>RoboHelp HTML Basics</td>
<td>2</td>
</tr>
<tr>
<td>Preview a Generated Project</td>
<td>3</td>
</tr>
<tr>
<td>Create a Project</td>
<td>4</td>
</tr>
<tr>
<td>Pods and Toolbars</td>
<td>7</td>
</tr>
<tr>
<td>Explore the Pods</td>
<td>8</td>
</tr>
<tr>
<td>Explore the Toolbars</td>
<td>11</td>
</tr>
<tr>
<td>Environments</td>
<td>13</td>
</tr>
<tr>
<td>Load the Default Environment</td>
<td>13</td>
</tr>
<tr>
<td>Save an Environment</td>
<td>14</td>
</tr>
<tr>
<td>Project Titles and Names</td>
<td>16</td>
</tr>
<tr>
<td>Retitle and Rename the Project</td>
<td>16</td>
</tr>
<tr>
<td>Topics</td>
<td>19</td>
</tr>
<tr>
<td>Edit a Topic</td>
<td>19</td>
</tr>
<tr>
<td>Edit a Topic Headline</td>
<td>21</td>
</tr>
<tr>
<td>Rename and Delete Topics</td>
<td>22</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>26</td>
</tr>
<tr>
<td>Create a TOC Book</td>
<td>26</td>
</tr>
<tr>
<td>Add, Delete and Rename TOC Books</td>
<td>28</td>
</tr>
<tr>
<td>Organize TOC Books</td>
<td>30</td>
</tr>
<tr>
<td>Add Pages to TOC Books</td>
<td>31</td>
</tr>
<tr>
<td>Generating</td>
<td>33</td>
</tr>
<tr>
<td>Generate a Project</td>
<td>33</td>
</tr>
</tbody>
</table>

## Module 2: Adding Content and Creating Project Structure

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>WebHelp</td>
<td>38</td>
</tr>
<tr>
<td>Preview the Completed Project</td>
<td>39</td>
</tr>
<tr>
<td>Create a WebHelp Project</td>
<td>40</td>
</tr>
<tr>
<td>Adding Content</td>
<td>42</td>
</tr>
<tr>
<td>Import an HTML File</td>
<td>44</td>
</tr>
<tr>
<td>Import a Word Document</td>
<td>45</td>
</tr>
<tr>
<td>Import a FrameMaker File</td>
<td>47</td>
</tr>
<tr>
<td>Rename Topic Titles</td>
<td>50</td>
</tr>
<tr>
<td>Project Structure</td>
<td>52</td>
</tr>
<tr>
<td>Create Project Folders</td>
<td>52</td>
</tr>
<tr>
<td>Auto-Create a TOC</td>
<td>54</td>
</tr>
</tbody>
</table>
## Contents

### Module 3: Topic Formatting
- Cascading Style Sheets ................................................................. 60
- Preview the Completed Project ...................................................... 61
- Apply a Style Sheet to a Topic ..................................................... 62
- Apply Styles to Selected Paragraphs ........................................... 65
- Custom Style Sheets .................................................................... 67
  - Create a New Style Sheet ......................................................... 68
- Font Sets ....................................................................................... 71
  - Create a Font Set ....................................................................... 71
- Inline Styles .................................................................................. 73
  - Use Inline Styles ........................................................................ 73
- Spell Check .................................................................................... 75
  - Use Spell Check ......................................................................... 75
- Find and Replace Content .............................................................. 78
  - Find and Replace Text ............................................................... 78
- Linking to Content ......................................................................... 80
  - Link to a Word File ................................................................. 80
- Compliant WebHelp ....................................................................... 84
  - Generate 508 and W3C Compliant WebHelp ......................... 84

### Module 4: FlashHelp, Links, PDFs and Popups
- FlashHelp ..................................................................................... 88
  - Preview the Completed Project .................................................. 88
  - Generate FlashHelp Output ....................................................... 89
- Custom Toolbars .......................................................................... 91
  - Create a New Toolbar ............................................................... 91
  - Add Commands to a Toolbar ................................................... 92
- Links .............................................................................................. 94
  - Insert Hyperlinks ....................................................................... 94
- Bookmarks ..................................................................................... 97
  - Insert Bookmarks ...................................................................... 97
- Importing PDFs ........................................................................... 99
  - Import a PDF Document .......................................................... 99
- Popups .......................................................................................... 102
  - Insert Auto-Sizing Popups ......................................................... 102
- Custom-Sized Popups ................................................................. 106
  - Insert Custom-Sized Popups ................................................... 106
- Text-Only Popups ........................................................................ 107
  - Insert a Text-Only Popup .......................................................... 107
- Link View ...................................................................................... 109
  - Use Link View .......................................................................... 109
- Broken Links ................................................................................. 110
  - Resolve Broken Links ............................................................. 110
Module 5: Graphics and Multimedia
Graphics ................................................................. 114
  Preview the Completed Project ........................................ 115
  Add Graphics to a Help Project ....................................... 116
  Add an Image Margin ..................................................... 118
  Rename an Image .............................................................. 118
Background Images ......................................................... 120
  Add a Background Image ................................................... 120
Image Maps ................................................................. 123
  Add Hotspots to a Graphic ............................................... 123
Sound ................................................................. 126
  Add Sound to a Topic ....................................................... 126
Captivate Integration .................................................. 128
  Import and Format Topics ............................................... 128
  Insert an Adobe Captivate Demo ..................................... 132
RoboScreenCapture ................................................... 134
  Create a Screen Capture ............................................... 134
A Quiz and a Lab .............................................................. 139

Module 6: Build Tags, Variables and Snippets
Conditional Build Tags ............................................... 144
  Create Conditional Build Tags ....................................... 144
  Define a Build Tag Expression ...................................... 148
Multiple TOCs .............................................................. 152
  Create a New Table of Contents ..................................... 152
User Defined Variables ............................................. 154
  Create a Variable .............................................................. 154
  Insert and Edit a Variable .............................................. 156
Snippets ................................................................. 158
  Create a Snippet .............................................................. 158
  Add a Snippet to a Topic ............................................... 160

Module 7: Tables and DHTML
Tables ................................................................. 164
  Preview the Completed Project ........................................ 164
  Insert a Table ................................................................. 165
  Insert a Table Row .......................................................... 167
  Duplicate a Table Style .................................................... 168
  Change Table Properties .................................................. 171
Lines, Symbols and Lists ............................................. 174
  Add a Horizontal Line .......................................................... 174
  Insert a Symbol ................................................................. 175
  Add a Bulleted List .............................................................. 176
Dynamic HTML .............................................................. 179
  Format a Heading With a Fade-in DHTML Effect ............... 179
  Apply Fly-in DHTML Effects ........................................... 182
Positioned Text Boxes .................................................. 186
  Work With Positioned Text Boxes .................................... 186
Triggers ............................................................. 190
  Create a Trigger ................................................................. 190
Module 8: Indexes, Search Terms, Glossaries and Docs

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Indexes</td>
<td>192</td>
</tr>
<tr>
<td>Preview the Completed Project</td>
<td>193</td>
</tr>
<tr>
<td>Run the Smart Index Wizard</td>
<td>194</td>
</tr>
<tr>
<td>Remove and Add Index Entries</td>
<td>197</td>
</tr>
<tr>
<td>Add Keywords via Topic Properties</td>
<td>198</td>
</tr>
<tr>
<td>Subkeywords</td>
<td>200</td>
</tr>
<tr>
<td>Add Subkeywords to the Index</td>
<td>200</td>
</tr>
<tr>
<td>See Also Keywords</td>
<td>202</td>
</tr>
<tr>
<td>Create a See Also Keyword</td>
<td>202</td>
</tr>
<tr>
<td>Insert a Link Control</td>
<td>203</td>
</tr>
<tr>
<td>RoboHelp Search</td>
<td>206</td>
</tr>
<tr>
<td>Add Custom Search Terms</td>
<td>206</td>
</tr>
<tr>
<td>Glossaries</td>
<td>208</td>
</tr>
<tr>
<td>Add Glossary Terms</td>
<td>208</td>
</tr>
<tr>
<td>Reports</td>
<td>212</td>
</tr>
<tr>
<td>Generate a Report</td>
<td>212</td>
</tr>
<tr>
<td>Printed Documentation</td>
<td>214</td>
</tr>
<tr>
<td>Generate Printed Documentation</td>
<td>214</td>
</tr>
</tbody>
</table>

Module 9: Forms and Frames

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forms</td>
<td>218</td>
</tr>
<tr>
<td>Preview the Completed Project</td>
<td>218</td>
</tr>
<tr>
<td>Create a New Topic</td>
<td>219</td>
</tr>
<tr>
<td>Insert a Form and Form Element</td>
<td>220</td>
</tr>
<tr>
<td>Add Radio Buttons</td>
<td>221</td>
</tr>
<tr>
<td>HTML Editing</td>
<td>223</td>
</tr>
<tr>
<td>Add HTML Code to a Topic</td>
<td>223</td>
</tr>
<tr>
<td>Check Boxes and Drop-Down Menus</td>
<td>224</td>
</tr>
<tr>
<td>Add a Check Box</td>
<td>224</td>
</tr>
<tr>
<td>Insert a Drop-Down Menu</td>
<td>225</td>
</tr>
<tr>
<td>Add a Multi-line Text Field</td>
<td>227</td>
</tr>
<tr>
<td>Submit and Reset Buttons</td>
<td>228</td>
</tr>
<tr>
<td>Add Submit and Reset Buttons</td>
<td>228</td>
</tr>
<tr>
<td>Form Properties</td>
<td>229</td>
</tr>
<tr>
<td>Name a Form and Set an Action</td>
<td>229</td>
</tr>
<tr>
<td>Frames</td>
<td>230</td>
</tr>
<tr>
<td>Import HTML Files</td>
<td>230</td>
</tr>
<tr>
<td>Create a Frameset</td>
<td>232</td>
</tr>
<tr>
<td>Modify Frameset Attributes</td>
<td>237</td>
</tr>
<tr>
<td>Link Topics Into Frameset Regions</td>
<td>239</td>
</tr>
</tbody>
</table>
Module 10: Skins and Master Pages

Skins .................................................................................................. 244
  Preview the Completed Project ......................................................... 244
  Attach a Skin to a Layout ................................................................. 245
  Create a Custom Skin ..................................................................... 247
  Customize the Search Highlight Color ............................................ 251
Master Pages, Headers and Footers
  Create a Master Page ...................................................................... 252
  Edit a Master Page ......................................................................... 256
Breadcrumbs .................................................................................... 257
  Add a Breadcrumb Placeholder to a Master Page ............................ 257
Mini TOCs ......................................................................................... 258
  Add a Mini TOC Placeholder to a Topic .......................................... 258
Publishing Projects ........................................................................ 260
  Publish a Project ........................................................................... 260

Module 11: Windows, Browsing and CSH

Custom Windows ........................................................................... 266
  Create a Custom Window ................................................................ 266
Browse Sequences ........................................................................ 270
  Create a Browse Sequence ............................................................ 270
Application Help ........................................................................... 272
  Review a Web Application’s Source Code .................................... 272
  Publish a WebHelp Project ............................................................ 274
Context Sensitive Help ................................................................... 276
  Review Source Code ..................................................................... 276
  Create a Custom WebHelp Window ............................................. 278
  Create a Map File and Assign Map IDs ........................................ 279

Module 12: Scripts and AIR Help

Scripts ............................................................................................ 282
  Run a Script ............................................................................... 282
  Edit a Script ............................................................................. 283
Adobe AIR ..................................................................................... 285
  Create an Adobe AIR Layout ..................................................... 285
  Output Browser Based AIR Help ................................................ 286
  Output Adobe AIR Application Help .......................................... 288
About This Book

About the Author

Kevin A. Siegel is the founder and president of IconLogic, Inc. He has written more than 100 step-by-step computer training books, including Essentials of Adobe Captivate 4, Essentials of Adobe Captivate 3, Essentials of Adobe Dreamweaver CS3, Essentials of QuarkXPress 7, Accelerated QuarkXPress 6, Essentials of Adobe InDesign CS3, Essentials of Adobe PageMaker 7 and Essentials of Adobe RoboHelp 6 HTML.

Kevin spent five years in the U.S. Coast Guard as an award-winning photojournalist and has more than 25 years experience as a print publisher and technical writer. He is a certified technical trainer, has been a classroom instructor for more than 16 years and is a frequent speaker at trade shows and conventions. Kevin holds multiple certifications from Adobe and the CompTIA. You can reach Kevin at ksiegel@iconlogic.com.

About IconLogic Books

IconLogic books are unique! They are created by instructors with years of software training experience. Before IconLogic books, our instructors rarely found a book that was perfect for a classroom setting. If the book was beautiful, odds were that the text was too small to read and hard to follow. If the text in a book was the right size, the quality of exercises left something to be desired.

Finally tiring of using inadequate materials, our instructors started teaching without any books. Over the years, we’ve had many students ask if the in-class instruction came from a book. If so, they said they’d buy the book. That sparked an idea. We asked students — just like you — what they wanted in a training manual. You responded, and the results appear in this book.

We hope you enjoy the book. If you have any comments or questions, please see page x for our contact information.
Book Conventions

This book has been divided into several modules. Since each module builds on lessons learned in a previous module, we recommend that you complete each module in succession.

During every module, you will be guided through lessons step by step. Instructions for you to follow will look like this:

 instructions for you to follow will look like this

If you are expected to type anything or if something is important, it will be set in bold type like this:

 type 9 in the box

If you are expected to press a key on your keyboard, the key will be in brackets like this:

 press [Ctrl]

Confidence Checks

You will also come across the little guy at the right. He indicates a Confidence Check. Throughout each module you will be guided through hands-on exercises. But at some point you’ll have to fend for yourself. That is where Confidence Checks come in. They’re very important. You must be sure to complete each of them because some exercises build on completed Confidence Checks.
Student Data Files

The data files necessary to complete the student activities in this book are available for download via our Web site. You will be walked through the steps necessary to download the files during the following activity.

Student Activity: Download Data Files From the IconLogic Data Files Server

1. Download the data files necessary to complete the lessons presented in this book.
   - start your Web browser and go to the following Web address: http://www.iconlogic.com/
   - click the Data Files for IconLogic Workbooks link
   - click the PC link
   - click the RoboHelp 8 HTML, Essentials of link
   - click Save when prompted
   - navigate to your desktop
   - click Save

   The zipped data files should be downloaded to your desktop as an EXE file.

2. After the file has fully downloaded, close the Web browser.

3. Extract the data files.
   - find the RoboHelp8Data.exe file you just downloaded to your desktop
   - double-click the file to open it
   - confirm C:\ appears in the Unzip to folder area
   - click Unzip
   - click OK
   - click Close

   The data files needed for the lessons in this book are now on your hard drive (C:\) in a folder called RoboHelp8Data. As you move through the lessons in this book, you will be opening files from and saving to the data folder. When you have completed the lessons in this book, you can delete both the RoboHelp8Data folder and the RoboHelp8Data.exe file you downloaded.

Software and System Requirements

You will need the following software and hardware before beginning the lessons in this book:

Adobe RoboHelp 8 (you can download a trial version from www.adobe.com/products/robohelp/), 1GHz or faster processor, Microsoft Windows XP with Service Pack 2 (Service Pack 3 recommended) or Windows Vista with Service Pack 1 (certified for 32-bit editions); 512MB of RAM (1GB recommended); 1.2GB of available hard-disk space for installation; 1,024x768 display (1,280x800 recommended) with 16-bit video card.
Need More Books?
We are proud to offer books on the following subjects:

**Print Publishing (Page Layout)**
- InDesign CS2 through CS3
- QuarkXPress versions 7 through 8

**Graphics and Multimedia Tools**
- Captivate versions 2 through 4
- PowerPoint 2002

**Help Authoring/Technical Communication**
- Adobe RoboHelp HTML versions 6 through 8
- Introduction to Adobe’s Technical Communication Suite 2
  (An Introduction to Adobe RoboHelp, Captivate and FrameMaker)

**Web Page Design and Development**
- Dreamweaver versions 8 through CS3
- HTML Basics

**Writing and Grammar**
- Adobe Captivate 3: Script Writing and Production Guide

**Print Publishing (Page Layout)**
- InDesign CS2 through CS3

And there are more coming all the time.

**To order, contact**

**IconLogic, Inc.**
3320 Breckenridge Way | Riva, MD 21140 | 410.956.4949
Web: [www.iconlogic.com](http://www.iconlogic.com) | Email: [iconlogic@iconlogic.com](mailto:iconlogic@iconlogic.com)

**Special Thanks**
I’d like to thank John Daigle, Rick Stone, Peter Grainge, Joyce Nolan, Lorraine Smith, Kim Wendkos, AJ Barker, Barbara Ash and Janet Tonner for their hard work and support during the production of this book.

~ Kevin A. Siegel
Module 1: Introduction to RoboHelp

In This Module You Will Learn To

- Preview a Project
- Create a Blank Project
- Explore the Pods
- Explore the Toolbars
- Load the Default Environment
- Save an Environment
- Retitle and Rename the Project
- Edit a Topic
- Edit a Topic Headline
- Rename and Delete Topics
- Create a TOC Book
- Add, Delete and Rename TOC Books
- Organize a TOC
- Add Pages to TOC Books
- Generate a Project
RoboHelp HTML Basics

RoboHelp HTML is the industry standard for Help authoring. It’s the preferred program if you are a Help author, technical writer or programmer tasked with creating Help systems for desktop or Web-based applications.

RoboHelp 8 HTML has the letters HTML in its name; therefore, many people think that RoboHelp is a Web page development tool (much like Adobe Dreamweaver)—it is not. Although you can create terrific Web sites using RoboHelp, its primary mission is to let you quickly and easily create Help systems.

I bet you’ve got a few questions right off the bat. First, what’s a Help system? And second, if RoboHelp isn’t a tool for creating Web pages, why does its name contain the letters HTML?

Great questions. Let’s start with the definition of a Help system. Simply put, a Help system is meant to provide information to a user (or customer) via a computer or mobile device. While most Help systems are designed to give assistance on a particular software application or operating system, Help systems can be used to present information on just about anything (such as a corporate policies guide).

How about RoboHelp’s name? HTML? RoboHelp HTML stands for Hypertext Markup Language. Simply put, HTML is a formatting language. You put codes (markups) inside text files so that they can be read by browsing software. Currently, the two most popular browsing programs are Microsoft’s Internet Explorer and Mozilla FireFox.

In previous versions of RoboHelp, your projects used HTML in the background as you worked on your content. At no time has there ever been a need to know HTML to create RoboHelp Help systems.

While older versions of RoboHelp relied on HTML as the “under the hood” language to create content, RoboHelp HTML 8 actually uses XHTML—the Extensible Hypertext Markup Language. XHTML, an application of XML, is similar to HTML (except for slight differences in the markup).

Which leads us directly to XML—the Extensible Markup Language. XML allows people to create customized tags that enable the definition, transmission, validation and interpretation of data between applications.

**Note:** If you open legacy RoboHelp projects in RoboHelp HTML 8, RoboHelp automatically upgrades all of the old HTML topics to XHTML.

HTML, XML, XHTML, markup, codes, extensible… ouch! This stuff sounds confusing. Maybe you’d better give up on this RoboHelp thing and pick a different career. Perhaps this Help authoring business is going to be too difficult? Nahhhh. I dropped a couple of acronyms on you just so I could feel better about myself. As I mentioned earlier, you don’t have to know anything about HTML, XML or XHTML to create Help systems. In fact, you can let RoboHelp worry about that stuff. Your job is to learn RoboHelp (that’s what this book is designed to do). After you’ve done that, gather the content, images, animation and other assets, and use RoboHelp to generate everything into a Help system format for your target audience.
Getting Started

The process of creating a Help system in RoboHelp begins with creating the basic elements (Projects and Topics). You’ll author your content (topics), track and manage the project files, and develop navigation (links, Tables of Contents, Indexes and Browse sequences).

In this first module, you will begin to familiarize yourself with RoboHelp terminology and the RoboHelp work environment.

One of the first skills you will learn is creating topics. As mentioned earlier, each topic you create or import becomes an XHTML file complete with all necessary tags to allow viewing by a Web browser.

After creating the topics, you will organize your topics into books within a Table of Contents so that users can find your topics via the Contents tab in the finished Help system.

Note: If you have not already copied your RoboHelp8Data student data files to your hard drive, complete the “Download Data Files From the IconLogic Data Files Server” activity that begins on page ix.

Student Activity: Preview a Generated Project

1. Preview a completed project.
   - using Windows Explorer, not RoboHelp, open My Computer (Vista users, open Computer)
   - open the C drive and then open the RoboHelp8Data folder
   - navigate to finishedProjects
   - open Learning_RoboHelp.chm

   Note: If your folder options have been set to Hide extensions for known file types, the extension chm may not be visible.

   This is the finished project you will be creating during this first module (shown pictured at the right).
   - double-click the Print Publishing book to open it
   - open the Applications book
   - click once on some of the pages you find inside the book to see the topics appear at the right

2. When finished exploring the Help system, close all windows.
Student Activity: Create a Project

1. Start the RoboHelp Starter.
   - choose Start > All Programs > Adobe RoboHelp 8 > RoboHelp HTML
   The RoboHelp Starter appears.

2. Show the New Project dialog box.
   - from the Create New area of the Starter, click More
   The New Project dialog box appears. There are two tabs: New and Import.
   - on the New tab, select the Application Help Project Type
   - review the information about the project that appears at the right of the dialog box
select the eLearning Project Type and review the information about the project that appears at the right of the dialog box

select the Blank Project Project Type and review the information about the project that appears at the right of the dialog box

ensure Blank Project is selected and then click OK

The New Project Wizard dialog box appears. This is where you will give the project a title, file name and project location.

3. Title a project.

in the Enter the title of this project area, type Learning RoboHelp HTML

Project titles will be seen in the title bar of your project by your end-users. The title can be descriptive and can contain spaces.

4. Name a project.

in the Enter the file name for the project area, type Learning_RoboHelp

A project’s file name will not be seen by your users. However, the project file name will be used when you generate your output files as the Start page for your Help system (you will learn about generating output files later). Since you are likely to store your generated Help system output files on a Web server, where file names with spaces can cause myriad problems, you should not uses spaces in any file name.

5. Specify a working location for the project.

in the Enter the location for the project area, click the yellow folder at the right of the dialog box

navigate to C:\RoboHelp8Data\RoboHelpProjects (you should have copied your RoboHelp8Data files to your hard drive earlier)

once inside the RoboHelpProjects folder, click the Open button

The location of your first project should now be C:\RoboHelp8Data\RoboHelpProjects. If you saved your data folder to a different location, you can still proceed. However, some steps in this book will not exactly match what you see on your screen.
6. Specify a title for the project’s first topic and the language to be used.

☐ in the **Enter the title of the first topic** area, type **InDesign**

☐ ensure **English (US)** is selected from the Language drop-down menu

☐ click **Finish**

A folder called **Learning_RoboHelp** has been created in the projects folder of RoboHelp8Data. All of the files you create for this particular project will automatically be added to your new folder. Now that you have clicked Finish, you are ready to begin working.
Pods and Toolbars

When a new RoboHelp project first opens, the project contains one topic. The lone topic is this project contains a headline that reads **InDesign**, and there are two placeholder paragraphs in the topic. The headline text you see is a direct result of you typing **InDesign** as the title of the first topic just a moment ago. You will soon be editing the topic and creating others.

The RoboHelp window contains several panels. The panels are known as Pods, and you’ll become familiar with them soon. Pods are windows that can float anywhere in the RoboHelp window. There are also several toolbars near the top of the window.

Your RoboHelp window should look similar to the picture below.
Student Activity: Explore the Pods

1. Explore the Snippet Pod.
   - choose View > Pods > Snippet

   The Snippet pod appears in the upper left of the window, just below the toolbars. You can add custom HTML code snippets to a project and insert them later into a desired topic. When you modify a code snippet shared by different topics, the changes to the code snippet are reflected in all the associated topics.

2. Reposition a pod.
   - at the top left of the Snippet pod, drag the word Snippet to the middle of the RoboHelp window to reposition the Snippet pod

3. Return the Snippet pod to its default location
   - double-click the Snippet pod’s title bar

   The Snippet pod should once again appear in the upper left of the RoboHelp window.
4. Explore the Project Manager pod.
   - choose View > Pods > Project Manager

   The Project Manager pod appears in the upper left of the RoboHelp window, just below the toolbars. You can use the Project Manager to edit, delete and create project files.

5. Expand and collapse the folders in the Project Manager pod
   - from the main RoboHelp menu, choose View > Expand All
   All of the folders within the Project Manager pod open.
   - from the main RoboHelp menu, choose View > Collapse All
   All of the folders within the Project Manager pod close.

6. Close all of the pods and windows by clicking the X in the upper right of each window.

   Your RoboHelp window should look like this:
7. Open a topic using the Topic List pod.

☐ choose View > Pods > Topic List

A list of the project topics appears in a pod at the bottom of the RoboHelp window. As your project grows, the list of topics in the list will grow. Currently, only one topic appears in the list.

☐ on the Topic List, double-click the word InDesign to open the topic for editing

InDesign
This is the first topic in your project. Delete this text and replace it with your own. To add a new topic, click the New Topic button on the tool bar.

To learn more about the Editor, press F1 (with your cursor in this pane) to display Help.
Student Activity: Explore the Toolbars

1. View and Explore the Project toolbar.
   - choose View > Toolbars > Project Toolbar (if the toolbar was already showing, you will have to repeat this step one more time)
   - slowly point to the second tool on the far left of the Project toolbar
     The tooltip Save All should appear (if you moved slowly enough).
   - slowly point to the third tool on the toolbar
     The tooltip Generate Primary Layout should appear.

2. View the Formatting toolbar.
   - choose View > Toolbars > Formatting (if the toolbar was already showing, you will have to repeat this step one more time)
   - slowly point to the sixth tool on the Formatting toolbar
     The tooltip Change Font Color should appear. (Tooltips are the popups that appear when you point to a tool.)
Confidence Check

1. View the **Tables and Borders** toolbar.

2. Spend a moment viewing the tooltips for the tools on the Tables and Borders toolbar.

3. Click inside the InDesign topic window to ensure that the topic is active. (The menus and available commands are different depending on what is active within RoboHelp.)

4. Spend a moment looking inside the menus across the top of your window (File, Edit, View, Format, etc.), and explore the available commands.

5. Which menu contains the command **Insert/Edit Dynamic HTML Effects**?

6. Which menu contains the command **Spell Check Project**?

7. Which menu contains the command **Adobe Captivate Demo**?

8. Which menu contains the command **Font Sets**?

Environments

If you share your computer with other team members, you will appreciate the ability to create multiple work environments within RoboHelp. For instance, if you find yourself working on the Snippets pod most of the day, you can create an Environment where the Snippets pod always appears in a specific location on your screen and is grouped with other pods you use frequently.

Student Activity: Load the Default Environment

1. Load the Default Environment.
   - choose File > Environment > Load Default Environment

   The RoboHelp window looks the way it did when you first saw the new project.

2. Close all of the pods and windows.

3. Load the Default Environment again.
Student Activity: Save an Environment

1. View and position pods.
   - drag the Project Manager pod to the middle of the RoboHelp window
   - choose View > Pods > Toolbox

   The Toolbox pod appears at the bottom of the RoboHelp window (in place of the Topic List pod).

   - drag the Toolbox pod up a bit so it floats in the RoboHelp window
   - close all of the other pods (the Toolbox and Project Manager should be the only open pods at this point)
   - position the Project Manager and Toolbox pods until your RoboHelp window looks similar to the picture below

2. Save the Environment.
   - choose File > Environment > Save Environment

   The Save As dialog box appears.

   - navigate to C:\RoboHelp8Data
   - change the File name to ProjectManager_Toolbox

   - click Save

   The environment has been saved with an RHS extension. You can load the environment into any RoboHelp 8 project.
3. Load the default and a saved Environment.

☐ choose **File > Environment > Load Default Environment**

The RoboHelp screen returns to its default appearance.

☐ choose **File > Environment > Load Environment**

The Open dialog box appears.

☐ open the *ProjectManager_Toolbox.rhs* Environment you created a moment ago (you should have saved the environment to the RoboHelp8Data folder)

![Open dialog box](image)

Both the Project Manager and Toolbox pods should reappear in the exact location specified when you created the Environment.

☐ choose **File > Environment > Load Default Environment**

The RoboHelp window returns to its default appearance.
Project Titles and Names

When you created this project (see page 4), you were instructed to title it Learning RoboHelp HTML and name it Learning_RoboHelp. If you were to generate the project now (it’s too soon to do that because your project does not have much in the way of content—yet), the title would appear in the title bar of the window when the generated Help system opens. The project file name corresponds to the default output file you generate. For instance, if you were to generate HTML Help, the output file you would create would be Learning_RoboHelp.chm.

You are about to learn how to change both the project title and project file name. Keep in mind that changing the project’s title (from Learning RoboHelp HTML to Becoming a Print Publisher) will not result in any obvious changes; however, after you generate the project, the resulting HTML Help window will display the new title. Changing the project name will instantly pay dividends—you will see the new title in the title bar at the top of the RoboHelp window as you continue to author your content.

Student Activity: Retitle and Rename the Project

1. Change the title of your project.
   - choose File > Project Settings
     - The Project Settings screen appears. Remember that you gave your project a title when you first created it. The Project Settings give you a chance to change the title. The title is important because it is the first thing your users will see when the Help system appears (the title appears on the window’s title bar).
   - if necessary, select the General tab
   - change the Title of the project to Becoming a Print Publisher
   - from the Primary Output drop-down menu, select Microsoft HTML Help
   - from the Language drop-down menu, ensure English (US) is selected

   - click OK

As mentioned above, changing the Project Title does not result in any obvious changes to your project. You will learn to generate the project on page 33, and the new title will appear in the Help window’s title bar.
2. Change the name of the project.

- choose **File > Rename Project**
- change the Project Name to **print_publishing**

- click **OK**

As the project is renamed, it will automatically close and then reopen.

**Note:** If you ever need to change the name of a RoboHelp project, do not change the project name outside of RoboHelp (for instance, do not change the project file name using Windows Explorer). While using Windows Explorer would certainly be an easy and tempting way to change the project name, doing so could lead to myriad problems too numerous to discuss here.
Confidence Check

1. Choose **Tools > Options**.
   The Options screen will appear. There are three tabs.

2. Click on each tab and review the contents.

3. Select the **General** tab.
   You can remove projects appearing in the Project List that you see when you first start RoboHelp.

   If you want, you can clean up the recently used list by selecting the file name and clicking the **Delete** button. (You can elect to leave the file names alone—deleting files via this method will not affect the lessons in this book.)

4. Ensure the rest of the General options match the picture at the right.

5. Select the **Associations** tab.
   Ensure your options match the picture below. (You want to ensure that your topics always open within RoboHelp when you intend to edit them.
   In the HTML Editors area, select Design View and click the **Set As Default** button. Then click the **Use Default Editor** radio button at the bottom of the dialog box.)

6. Click **OK** to close the Options dialog box.
   The changes you have just made while in the Options dialog box will not have an obvious effect in RoboHelp.
Topics

Your generated Help project will contain at least three navigation options at the top of the Help window: Contents, Index and Search. When users click the Contents tab, they will typically see books that, if opened, will lead to additional books and/or topics.

Your project currently contains just one topic (InDesign) and no books. In the next few activities, you will edit the existing topic, add new topics and add books (the books will house your topics and will appear on the Contents area of your generated Help system).

Topics are quite possibly the most important part of your project. Without well written, relevant topics, what kind of help would your Help system really be? Each new topic you make actually creates a single HTML file—you do not need to know HTML to create HTML topics.

Student Activity: Edit a Topic

1. Open and edit an existing topic.
   - from the Topic List pod at the bottom of the RoboHelp window, double-click the InDesign topic

   The InDesign topic opens in Design view, ready for your edits. You can switch between Design and HTML view by clicking either button located just above the ruler (which you can see just above the topic’s headline).

   By default, you’ll always be editing topics in the Design view. However, you can right-click a topic in the Topic List pod, select Edit With and choose another application (such as Word 2007 or NotePad). You could choose Tools > Options and, on the Associations tab, select Auto Select Editor. Selecting this option means that RoboHelp will attempt to open the topic in the application that created it.

   - highlight the words “This is the first topic in your project” through “To learn more about...”
   - replace the selected text with: InDesign is a print publishing application primarily used to produce magazines, brochures and flyers.

2. Save the project component.
   - click the Save Component tool on the Project toolbar
3. Create a new topic.
   - choose **File > New > Topic**

   The New Topic dialog box appears.
   - ensure that the **General** tab is selected and type **Welcome** into the Topic Title area

   Notice that a File Name has been assigned to your topic that currently matches the Topic Title. Although you can always change the File Name (either now or later), by default, RoboHelp prevents you from using spaces in topic file names.

   - click **OK**

   The new topic is created and opens in Design view. You can ensure that RoboHelp never uses spaces in new topic file names by choosing **Tools > Options**. On the **General** tab, ensure **Use underscores in file names** is checked. Why are spaces in file names a bad idea? There are many reasons. First and foremost, if you were to use spaces in the file names, your project would not Generate properly.

4. Add text to the new topic.
   - highlight the text **Type topic text here.**
   - type **This Help System will assist you with starting a career as a desktop publisher.**

At the top of the Welcome window, notice that there are three tabs: Starter, InDesign and Welcome. You can have multiple topics and windows open at the same time. To switch between open topics, you can simply click the name on the tab across the top of the window, press [ctrl] [tab] on your keyboard, or select the window from the Windows menu.

5. Click the **Save All** tool on the Project toolbar to save the Project.
Student Activity: Edit a Topic Headline

1. The Welcome topic should still be open and in Design view (not HTML view).

2. Show paragraph markers.
   - choose View > Show > Paragraph Markers

   You should be able to see a paragraph marker after the word Welcome. If you cannot see the paragraph marker, repeat the last step.

3. Change the name of an existing topic heading.
   - click after the word Welcome (just to the left of the paragraph marker)
   - press [spacebar]
   - type to the Resource Tool for Print Publishers

Notice that the heading appearing in Design view no longer matches the Welcome topic title of the file appearing in the list of HTML files in the Topic List pod. Each topic has two names: the topic title and file name. The heading you just edited has nothing to do with either the topic title or file name. The topic title, file name and main heading in the topic do not need to match, but keeping all three names similar might avoid confusion for your users and co-authors.
Student Activity: Rename and Delete Topics

1. Create a new topic using a shortcut menu.
   - in the Topic List pod, right-click and choose **New Topic** from the shortcut menu
   - name the new topic **Ooops**
   - confirm the File Name is **Ooops.htm**
   - click **OK**

2. Rename the topic title and file name.
   - right-click **Ooops** on the Topic List pod and choose **Properties** from the shortcut menu
   - change the Topic Title to **NewName**
   - change the File Name to **newname.htm**
   - click **OK**
The updated names appear in the Topic List pod.

3. Delete a topic.
   - on the Topic List pod, right-click **NewName** and choose **Delete**

You will be asked to confirm the deletion.

   - click **Yes**

The file has been removed from the RoboHelp project and moved to the Recycle Bin (the picture below shows an open Recycle Bin in Windows Vista).
Confidence Check

1. Create the following new topics:
   - QuarkXPress
   - PhotoShop
   - FrameMaker
   - Illustrator
   - Flash
   - Word

   You should now have eight topics—and they are all probably open.

2. Choose Window > Close All to close all of your topics (click Yes if you see the Save change confirmation dialog box).

3. Click the Save All tool on the Project toolbar to save the Project. (Keep in mind that saving components of your project is not the same as saving the project itself. If I were you, I would use the Save All tool frequently.)

4. Open the Flash topic from the Topic List. Highlight the text "Type topic text here" and replace it with the following:

   Flash is a program used to create interactive, multimedia presentations for the Web.

5. Replace the existing body text in the FrameMaker topic with:

   FrameMaker is a print publishing application primarily used to produce long, technical documents.

6. Replace the existing body text in the Illustrator topic with:

   Illustrator is a graphics program used to create original artwork.

7. Replace the existing body text in the PhotoShop topic with:

   PhotoShop is a powerful graphics program for manipulating scanned photographs and artwork.
8. Replace the existing body text in the QuarkXPress topic with:

**QuarkXPress is a print publishing application primarily used to produce magazines, brochures and flyers.**

9. Replace the existing body text in the Word topic with:

**Microsoft Word is a powerful word processor. Most people use Word to type a majority of their text and then import the text into print publishing programs such as InDesign, QuarkXPress and FrameMaker.**

10. Notice the red, underlined words in the Word topic. This is the **Check spelling as you type** feature.

11. **Right-click** any red, underlined word and choose Spelling from the shortcut menu. If the word is misspelled, a suggestion appears in the list. If the word is spelled correctly, you can elect to Ignore, Ignore All or Add to Dictionary. For the purpose of this book, when in doubt, choose Ignore All.

12. Click the **Save All** tool on the Project toolbar to save the Project and all of your open topics.

13. Close all of the topics (**Window > Close All**).
Table of Contents

A typical Help system has a Contents tab which you create in the Table of Contents folder on the Project Manager pod. A typical Contents tab is made up of books and pages. Books can contain pages or other books. The pages typically point to topics in your project.

Student Activity: Create a TOC Book

1. Toggle the Project Manager View.
   - choose View > Pods > Project Manager
   - on the Project Manager pod, click the Toggle Project Manager View tool (it’s the first tool on the Project Manager pod and will look like one of the two tools shown at the right)
   - There are basically two Project Manager views: Global and Detail. Unless otherwise instructed to do so in this book, please ensure that the Project Manager remains in Global view (which is shown below).

2. Open the Table of Contents folder.
   - on the Project Manager pod, double-click Table of Contents to open the folder
   - There is currently a default Table of Contents called Learning_RoboHelp within the Table of Contents folder. You can edit the default or create your own. You will learn to work with new TOCs later. For now, you will edit the default.

3. Rename the Table of Contents.
   - right-click the existing Table of Contents and choose Rename
   - change the name to print_pub and press [enter]
4. Add a book to the Table of Contents.

- double-click print_pub (Default)

The TOC opens in its own pod to the right of the Table of Contents folder.

- from the top of the print_pub (Default) pod, click the New TOC Book tool (shown at the right)

The New TOC Book dialog box appears.

- confirm that the General tab is selected
- type Print Publishing Applications into the Book Title area
- ensure Book with Link is NOT selected

If you select Book with Link, you will only be able to associate the book with a single topic. By keeping the option deselected, you will be able to add multiple topics to the book (something you will do very soon).

- click OK

Congratulations! You’ve just added your first book to a TOC.
Student Activity: Add, Delete and Rename TOC Books

1. Use a tool to create a new book.
   - from the top of the print_pub (Default) pod, click the New TOC Book tool (shown at the right)

   The New TOC Book options appear again.
   - type Delete Me into the Title area
   - click OK

   A new book called Delete Me appears on the TOC.

2. Delete the newest book.
   - confirm that Delete Me is the selected book (you don’t want to accidentally delete the Print Publishing book)
   - press [delete] on your keyboard

3. Add a new book by right-clicking.
   - right-click just beneath the Print Publishing book
   - choose New > Book from the shortcut menu

   The New TOC Book Properties dialog box appears again.
   - type Rename Me into the Title area
   - click OK

   A new book called Rename Me appears beneath your first book.

4. Rename the book.
   - right-click the book named Rename Me
   - select Rename from the shortcut menu

   The book’s text is selected. You can now type a new name.
   - type Delete Me
   - press [Enter] on your keyboard to activate the new name

Note: Deleting books and pages from the TOC does not delete project topics or other assets from your computer and throw them into the Recycle Bin. Instead, deleted TOC books and pages are simply deleted from the project file.
Confidence Check

1. Delete “Delete Me.”
2. Rename the book Print Publishing Applications as Print Publishing.
3. Create a new book with the name Applications.
4. Create a new book with the name Training.
5. Create a new book with the name Careers.
6. Create a new book with the name Pricing.
7. Compare your TOC to this:

![TOC Image]

8. Save your work.
Student Activity: Organize TOC Books

1. Move books.
   - select the Careers book on the TOC
   - from the top of the TOC pod, click the Move Right tool
     The Careers book moves right and is now considered a nested book.
   - with the Careers book selected, click the Move Left tool
     The Careers book moves left.
   - with the Careers book selected, click the Move Down tool (you may have to look for the Move Down tool from among the additional tools hiding in the Toolbar options area or make the TOC pod wider)
   - with the Careers book selected, click the Move Up tool at the top of the TOC
     The Careers book moves back to its original position.

2. Save your work.

Confidence Check

1. Move the following books right: Applications, Training, Careers, Pricing.
   Your TOC should look like this:

   ![TOC Diagram]

2. Save your work.
Student Activity: Add Pages to TOC Books

1. Add a topic to a book.
   - select the **Applications** book on the **print_pub (Default)** pod
   - at the top of the print_pub pod, click the **New TOC Page** tool

   The New TOC Page dialog box appears.
   - select **Flash** from the list of topics
   - confirm that **Flash** now appears in the Page Title area

   - click **OK**

2. Your TOC should now look like this (one of your topics has been added to the Applications book on the TOC).

   - Save your work.
Confidence Check

1. Add all of the remaining topics as **New TOC Pages** to the Applications book (including Welcome).

2. Select the Welcome page on the TOC and drag it above the Print Publishing book.

3. Delete the **Training** book.

4. Delete the **Careers** book.

5. Delete the **Pricing** book.

   Your TOC should look like this (the order of the topics within the book is not important):

6. Save your work.
Generating

Believe it or not, you have already created books and topics, the basis behind most RoboHelp HTML projects. For the RoboHelp project to work properly if viewed by users, you must **Generate** (also known as compiling) the project using the **Generate Primary Layout** tool. You must always remember to generate the project if you make any changes to the project and/or when you are finished creating the project.

Student Activity: Generate a Project

1. Open the Single Source Layouts pod.
   - choose **View > Pods > Single Source Layouts**

2. Select a Default Topic.
   - on the Single Source Layouts pod, right-click **Microsoft HTML Help (Primary Layout)** and choose **Properties**

   The HTML Help Options dialog box appears. The Output Folder and File Name area tells you what your published file will be called (**print_publishing.chm**), and where you can find it on your hard drive (**C:\RoboHelp8Data\RoboHelpProjects\Learning_RoboHelp\!SSL\\Microsoft_HTML_Help**). After generating the CHM file, you would give the CHM to the application developer, or to your IT team, so it can be deployed.

   The Default Topic is the first topic users will see when the Help system appears. In this case, you would like the Welcome topic to be the Default Topic.

   - click the **Select** button (to the right of the words **Default Topic**)
   - select **Welcome** from the list of existing topics
   - click **OK**
   - click **Save**

**Note:**
If Optimize CHM File Size is selected in the Properties dialog box, the size of your CHM file will be reduced by eliminating unnecessary HTML code in your topics.
3. Generate Microsoft HTML Help.

☐ click the **Generate Primary Layout** tool on the Project toolbar

As the project is generated, it is also compressed. The generation process takes only seconds, and then you will see **Compilation complete** at the bottom of the RoboHelp window in the Output View pod.

☐ click **View Result**

Your generated (compiled) project appears in a Help browser. This is exactly what your users and/or customers will see. Notice that the Welcome topic appears at the right of the window because it is the default topic.
Confidence Check

1. Open the Print Publishing book.
2. Open the Applications book and spend the next few moments opening the topics (pages) you find inside the book.
3. When finished exploring the generated Help window, close the compiled window.
4. Back in RoboHelp, close the project (File > Close Project).
5. Minimize RoboHelp so you can see your desktop.
6. Using Windows Explorer, navigate to the RoboHelp8Data folder on your hard drive.
7. Open the RoboHelpProjects folder
8. Open the Learning_RoboHelp folder.
   Inside the Learning_RoboHelp folder you will find that there are HTML files for each topic you created during this module. You should never delete the HTML files without using RoboHelp’s Project Manager or Topic List pod. If you delete a file outside of RoboHelp, you’ll receive error messages when you open the project in the future, and your project may not generate properly.
   You’ll also see several support files that RoboHelp needs to open your project and compile it. For instance, notice the file print_publishing.xpj. This is the project file and is the file that RoboHelp first opens when you open your project.
10. Open the Microsoft_HTML_Help folder.
    The file print_publishing.chm is the file that you would give to your users or developers.
11. Double-click the CHM file.
    The Help system you created during this module opens. Your users will not need the RoboHelp application to open the CHM file. In fact, if your users are using Windows 2000 or newer, they have everything they need already installed on their computers to open and use your CHM file.
12. Close all windows.
13. Return to RoboHelp so that you can begin work on the next module.