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TOCs
If you’d like to allow your customers to control the learning experience and navigate
(branch) through your lesson in any order they’d like, you can add a TOC to your
video during the Production process. The process of adding a TOC begins with adding
markers to your project (as you learned to do on page 126). When you add the TOC,
you can elect to use the marker names as the hyperlinks on your TOC, or make up
new names on the fly.
Note: Before attempting to work with a TOC, you must first complete
the “Markers” activity that begins on page 126.

Student Activity: Add a TOC
1. The MarkMe_TOCMe project should still be open.
2. Produce and share using Custom production settings.

 choose File > Produce and share (or press [Ctrl] [p])
 select Custom production settings from the drop-down menu

 click the Next button
3. Select the output format.

 if necessary, select MP4/FLV/SWF - Flash
outputs and then click the Next button

The Flash Templates dialog box opens. (If you are
using Camtasia 7.1, the dialog box is labelled Flash Controllers).
4. Select an Appearance Template.

 from the Template drop-down menu, select ExpressShow with TOC

(If you are using Camtasia 7.1, choose ExpressShow from the Controller
drop-down menu)

 ensure the Theme is set to Black

Camtasia 7 shown above, left. Camtasia 7.1 shown above right.

 click the Next button
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5. Disable the Watermark.

 from the Watermark area, deselect Include watermark
6. Create a Web page with the video.

 from the HTML area of the Video Options dialog box, select Embed video
into HTML

7. Produce the video.

 click the Next button

 click the Finish button
Your video will be rendered—depending on the processing power of your
computer, it could take a few minutes to complete.
8. Watch the finished video.

 click the Play button to start the video
Look at that... a TOC appears at the left of the
video and your markers appear, just like magic.
The TOC works (you can click the marker text
to prove that). However, you’ll notice that the
marker titles are so long they didn’t fit.
You’ll fix that soon.
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9. Review the published files.

 close the browser window
 click the Open production folder button on the Production Results
dialog box

The published files appear. If you wanted to upload this lesson to your Web
server, be sure to post all of these files. When creating a link that will start the
lesson, link to the HTML file (in this case, MarkMe_TOCMe.html). Once the
HTML file opens in the Web browser, the remaining files will open and your
lesson will play.

 close the MarkMe_TOCMe window
10. Back in Camtasia, click the Finish button (leave the MarkMe_TOCMe project
open).
11. Save your work.
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Student Activity: Customize a TOC
1. The MarkMe_TOCMe project should still be open.
2. Change the Dimensions of the TOC.

 choose File > Produce and share
 if necessary, select Custom production settings from the drop-down
menu






click the Next button
if necessary, select MP4/FLV/SWF - Flash outputs
click the Next button
if necessary, select ExpressShow with TOC from the Template dropdown menu (If you are using Camtasia 7.1, choose ExpressShow.)

 if you are using Camtasia 7, click the Change dimensions button
 if you are using Camtasia 7.1, choose Custom from the Video Size dropdown menu

The Video Dimensions - Preview screen opens.

 at the bottom of the screen, select the Custom radio button
 change the TOC width to 212

 press [Tab] on your keyboard
Notice that the new width is just wide enough to display your maker titles on
the TOC.

 click the OK button
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3. Change the Flash Options so that you produce a SWF.

 if you are using Camtasia 7.1, choose SWF from the File format drop-

down menu; if you are using version 7.0, click the Flash options button
and, on the Video tab, change the Format to SWF

You might find yourself in a debate as to what the SWF suffix stands for. Years
ago I was told that SWF stood for “Shockwave File.” In reality, the suffix once
stood for “Shockwave Flash.” The name was often confused with Macromedia’s
Shockwave format used for a program called Macromedia Director (that
program lives today as Adobe Director). To end the confusion, Macromedia
decided that SWF would forevermore stand for “Small Web Format.”
4. Add a title that will appear above the TOC.

 if you are using Camtasia 7.1, click the Flash options button; if you are
using version 7.0, you should already be in the Flash Options dialog box

 select the Table of Contents tab
 in the Title Area, type Working with Folders

5. Change the TOC Display options.

 on the Table of Contents tab, select Fixed-right from the Display options
at the bottom of the dialog box

 click the OK button
 click the Next button
You should now be on the Video Options screen of the Production Wizard.

 click the Next button
And finally, you’re on the Produce Video screen.

 change the Production name to MarkMe_TOCMe2
 click the Finish button
Your new video will be rendered.
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 click the Play button to start the video
Your updated TOC should appear (wider and at the right of the video). And
check out the title bar above the TOC. You’ll see the title you added.

6. Close the browser window.
7. Close the Production Results dialog box.
8. Save your work.
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Confidence Check
1. Produce the video again using Custom production
settings.
2. This time, when you get to the Flash Templates screen,
change the Template to One video with TOC.
3. Select Glass from the Themes drop-down menu.

4. Click the Flash options button and select the Controls tab.
5. From the Playback controls area,
select Show about box.
6. Type A presentation developed by and then
type your full name.
7. Click the OK button.
8. At the bottom left of the Flash Templates screen,
click the Preview button and choose Preview
current settings.
The Preview feature generates your project files to My Documents\Camtasia
Studio\Production Previews. You will usually find that previewing your video is
faster than waiting for the video to render (only to find problems and have to
render the video over again). Previews give you a good feel for how your
finished videos will look and behave. However, previews are not the same
quality as rendered videos. When ready to finish your project, you should
always render the video.
9. In the browser window that displays your
preview, click the button in the lower right of the
Playbar to see the information you typed a
moment ago.
10. Close the browser window and return to
Camtasia (the Production Wizard should still be
open on the Flash Templates screen).
11. Click the Next button (you should now be on the
Video Options screen).
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12. Click the HTML options button at the right and change the Title to Working
with Folders.

13. Click the OK button, click Next a couple of times and then click the Finish
button to render the video (you can overwrite the existing file when/if
prompted).
14. Play the video. The big thing to notice this time is your browser’s title bar
(or the tab title, depending on the Web browser you are using and its version).
You’ll see the page title that has been added thanks to the Title you just
added.

15. Close the browser window.
16. Back in Camtasia, click the Finish button.
17. Save your work.
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Hotspots
To maximize the effectiveness of your eLearning videos, you can add interactivity via
a Flash Hotspot. The hotspots you add can allow your customers to jump to specific
markers within a video, add hyperlinks to Web sites and more.
Several callouts can include a Flash Hotspot (by selecting Make Flash Hotspot). The
option is automatically included if you use a Transparent Hotspot, which you will be
adding to the project soon.
Here are the options available to you when you create a Flash Hotspot:
Pause at end of callout: Once clicked, the video will stop based on the callout’s end
time on the Timeline.
Click to continue: The viewer must click the callout to continue viewing the video.
Go to frame at time: The video jumps to a specific frame. You can enter the frame
to jump to in Hours:Minutes:Seconds;Frames.
Go to marker: The video jumps to a specific Timeline marker.
Jump to URL: Opens a Web page (enable the Open URL in a new browser window to
open the Web page in a separate window).
Note: To include a Flash Hotspot in your video, you must produce to
the Flash output (MPEG-4 or SWF).

Student Activity: Replace a Background Image
1. Using Camtasia Studio 7, open FlashHotSpotMe.camproj from the
Camtasia7Data folder.
2. Open a Title Clip for editing.

 at the beginning of the Video 1 Track on the Timeline, double-click the first
Title Clip

The Title Clip’s Properties appear.
3. Replace a background image.

 in the Background area, click the yellow folder
Image field

at the right of the

 from the Camtasia7Data/images folder, open BeginScreen.jpg
On the Preview panel, notice that the background image has been replaced.
This new one includes a “Begin Lesson” image in the lower right of the screen.
You will be adding a Flash Hotspot on top of the image of the button.
Your customers will be able to click the hotspot to begin the lesson.
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Student Activity: Add a Transparent Hotspot
1. The FlashHotSpotMe project should still be open.
2. Add a Transparent Hotspot Callout.

 with the Playhead at the beginning of the Timeline, choose Tools >
Callouts

 click the Add callout button
 click the button in the lower right of the Shapes panel
to display all of the shapes

 select Transparent Hotspot

On the Timeline, your new caption appears on the Callouts Track just beneath
the image on the Video 1 Track.

3. Set the Callout Properties.

 if necessary deselect both Fade in and Fade out from the Properties area
4. Size and position the callout on the Preview.

 move and resize the callout until both the size and position are similar to
the picture below
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Student Activity: Set Flash Hotspot Properties
1. The FlashHotSpotMe project should still be open.
2. Set the Flash Hotspot Properties.

 on the Timeline, double-click the Transparent Hotspot Callout you just
added (to ensure the Callout’s Properties are open)

 click the Flash hotspot properties button

 from the Action area, select Go to marker
 select Begin Lesson from the marker drop-down menu (you learned how
to create markers on page 126)

 click the OK button
3. Save your work.
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Confidence Check
1. Still working in the FlashHotSpotMe project, double-click
the last object on the Timeline.
2. Insert a second Transparent Hotspot Callout.
3. Resize the new callout so that it is as large as the preview
screen.

4. Set the Flash hotspot properties to Jump to URL and type
http://www.southrivertechnologies.com into the text field.
5. Ensure Open URL in new browser window is selected.

6. Click the OK button.
7. If necessary, change the Properties of the new
callout so that it does not Fade in or Fade out.
8. On the Timeline, stretch the new callout right so that
it ends when the video ends.
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9. Produce the video (select Web from the drop-down menu).

10. Watch the produced video and test the first hotspot (the first hotspot should
simply start the lesson).

When you click the second hotspot, there’s a good chance you’ll see the Adobe
Flash Player Security dialog box.
Note: If you did not see
the message at the left,
you can manually browse to
the Settings screen shown
on the next page via this
URL: http://bit.ly/
16SwkR.

So what’s the deal with the dialog box above? The Flash Player was designed
to provide security settings that do not require you to explicitly allow or deny
access in most situations. Over time, as SWF and FLV content have become
more sophisticated, the Flash Player has also become more sophisticated,
offering additional privacy and security protections.
The content you just published was created using older security rules. You can
allow the content to work as the Camtasia developers intended, using the
older security rules, or you can choose to enforce the newer, stricter rules.
The latter choice helps ensure that you only view or play content that meets
the most recent standards of security, but it may sometimes prevent your
video from working properly.
When some content runs in a newer version of the player, and the Flash Player
needs you to make a decision about enforcing newer rules or not, you may see
the dialog box on the previous page that asks your permission before allowing
the older SWF or FLV content to communicate with other locations on the
Internet.
Rest assured that your customers will not see the dialog box once your
published content is posted on a secure Web server. However, the following
steps will help you get past the Flash Security Warning on your computer.
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11. Click the Settings button to open the Global Security Settings page
(or start your default Web browser and go to http://bit.ly/16SwkR).

Note: You can manually
browse to the Settings
screen shown at the left via
this URL: http://bit.ly/
16SwkR.

12. From the Adobe Flash Player Settings Manager, click Always allow.
13. Click Edit locations and then click Add location.
14. In the Trust This Location dialog box, click the Browse for folder button.
15. Open the Camtasia7Data folder and click the OK button.

16. When finished, close all browser windows.
17. Click the Open production folder button on the Production Results dialog
box (this will open the FlashHotSpotMe folder).
18. From the FlashHotSpotMe folder, open FlashHotSpotMe.html
19. Test the second hotspot.
The hotspot should open the Web browser and SRT home page without
incident.
20. When finished, close all browser windows and close the Production Results
dialog box.
21. Save your work.
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