Learning Series

Creating Effective
“"Let Me Try” Movies

In This Lesson You Will Learn To
e Insert a Text Button
e Insert and Format a Highlight Box
e Add Click Boxes
e Add Text Entry Boxes

Show Me vs. Let Me Try Movies

There are two categories of movie you can create in Captivate. I have long
referred to them as “Show Me” and “Let Me Try.” In essence, a Show Me
movie demonstrates a concept. There is typically some interactivity such as
Buttons and Highlight boxes. However, a Show Me movie plays by itself.
The user is expected to sit back and watch captions appear on the screen and
the mouse move from menu item to menu item. Although there is nothing
wrong with Show Me movies, Let Me Try movies improve the learning
experience for your users by letting them actively participate in the movie.

The four primary methods of adding interactivity are Click Boxes, Text
Entry Fields, Buttons and Highlight boxes. This document will teach you
how to add all four elements to your movies.

Buttons

Buttons provide you with an easy way to add interactivity to a slide. There
are three types of buttons: Text, Transparent and Image. A Text button can
contain any word or phrase you care to type, such as “Continue” or “Begin.”
You have complete control over the font and font size used in the Text
button; however, the larger the font size, the larger the button will be. With a
Transparent button, the button cannot contain text, but you can control its
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{REA(G Frame and Fill color. With Image button, you can specify a different image for each
N button state: Up, Down and Over.
Insert a Text Button

1. Insert a Text button.

J open any movie in Macromedia Captivate
[ open any slide
[ choose Insert > Button

The New Button dialog box appears.

(J on the Button tab, select Text button from the Type area
[ type Continue into the Button text area
CrCE— Y

Button
Set button properties.

Button | Optiens | Audio | Reparting

1f the user dicks on the button

On success: Iconﬁnue LI
Continue: [ =

If the user dlick outside the button
Allow user: 1 = attemptsor [¥ Infiite attemts

After last attempt:  [Continue

Continue: [

Type: [rest button

Button text: Jcontinue

[~ Transparent

Fet shorteut key

Current shorteut:  Mouse dick only Selectkeys... ‘

oK | Cancel | Apply | Help |

[ click the Font button
[ change the Font to Verdana
[ change the Font Size to 10

Wingdings

Wingdmee s =
@ Woodtype Omamerts
& Woodtyps Omamerts x|

Hfects ~Sample

™ Strkeout

I Underine feEbyyze
Color:

. - Serpt:

(3 click OK
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(3 confirm Continue is selected from the If the user clicks on the
button area

Options
Set button properties.

Bation =

Button Options |Aud|u | Reporting |

Cancel Apply Help

3 click OK

A Continue button appears on the slide.

2. Set button options.

[ double-click the button
(J select the Options tab and change the Appear after to 3.5 seconds
(J change the Pause movie after to 0.1 seconds

(7 select Show hand mouse curser when over button from the
Options area

3 click OK

3. Preview the movie to test the button.
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Highlight Boxes

Highlight Boxes.

1. Insert and format a Highlight Box.
[ choose Insert > Highlight Box

The New Highlight dialog box appears.

[ change the Frame width to O

width to 0 is an effective workaround.

O click the little square to the right of
Fill color

[ select any color you like
3 click OK
[ change the Fill transparency to 70%

The higher you set the Fill transparency, the
less of your Fill color you will see.

CR— T
Highlight Box T
set highlight box properties, o '/"
Highlight Box |Dphcns| Audio |

—Appearance
Frame color: 1 Frame width: ID :II
Fill color: || Fill transparency: 70 :II o

Preview

[~ Apply properties to all “highlight boxes™ in the movie

OK I Cancel Ay Help

(3 click OK

Insert and Format a Highlight Box

Color

Basic colors:
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Define Custory Colors >>

q

If you want to make sure your users know exactly where they are supposed to look on the
screen, you can insert Highlight Boxes. You can control the size, color and timing of

There is no direct command in Captivate to eliminate a border around a Highlight
box. If you do not want a border to surround your Highlight boxes, setting the Frame

Hue:[T3 | Red:[255
L Set:f20 Green:[122

e m om

oKk | canedl |

Addito Custom Colors |

By default, the Highlight Box appears in the center of your slide.
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2. Resize and reposition the highlight box. NPT

(3 drag the center of the Highlight Box to a desired location
O resize the Highlight Box as necessary

k- O -3 ‘ ) sexch Folders

|Watch as the File
menu is selected

3. Play the slide.

Notice that the highlight box fades in as the slide plays, stays around the entire time
the slide plays and then fades out.

4. Set Highlight Box properties.
[ on the Timeline, double-click the Highlight Box object to show the
Highlight box properties
O select the Options tab
O change the Display for time to 2.0 seconds

J change the Appear after to =
1.0 second options

Set highlight box properties.

[J change the Transition Effect to

Highlight Box  Options |Audia |

Fade in only b
D click OK Display for: [specfictme =] 20 j seconds
Appearafie: L0 | scconds
5. Play the slide. (e e o
m: 0.5 =] seconds out; [1:5 = secards
Notice that the Highlight Box fades in ™ Apely effect to all highlght boxes" in the movie ‘
after one second and sticks around for
2 seconds.

OK o ) Help
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Click Boxes

Instead of telling and then showing users how to perform an action, you can add Click
Boxes that allow the user to perform actions such as clicking a menu or command.

Add Click Boxes

1.

Open any Captivate movie you have recorded and select all of the slides.

Hide the mouse for the entire movie.

(3 choose Slide > Mouse > Show Mouse

The mouse pointer has been hidden.

Insert and set user options for a Click Box.

(3 choose Insert > Click Box

The Click Box dialog box appears.

[ on the Click Box tab, ensure =
Continue is selected from the | diksox

Set dlick box properties. _'J.' )

If the user clicks inside the

click box, On success area Cick Box | Optons | Audio | Reporting |
(3 ensure Infinite attempts is e
selected from the If the user ol I L

clicks outside the click box,
Allow user area

i If the user dicks outside the dick box

Allow user: I_j attempts or  [W Infinite attempts
[ ensure Set shortcut key is set fter st attempt: [orirue =
to Mouse click only Continue: I -]
i Set shortout key
. . . . Current shortcut: Mouse dick only Select keys. .. |
Set timing options for a Click Box.
O click the Options tab | =

[ select rest of slide from the
Display for area

O change the Appear after to 1.0 seconds

O from the Options area, select Failure caption, Pause movie until
user clicks and Pause for success/failure captions

The Failure caption option will insert a Failure caption on the slide for you. This is
the caption that will appear if the user does not click on the click box. By selecting
Pause Movie until user clicks you ensure that the movie will not continue unless the
user clicks the click box. The Pause for success/failure caption ensures the user is
given a chance to read the Failure caption before getting frustrated and clicking again
in the wrong place.
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O if necessary, deselect the other options

New click box i x|
Options ™
Set click box properties. A /
Click Box Options |Audio I Reporting |

rTiming
Display for: |rest of slide 'I L5 j seconds
Appear after: 1.0 il‘l seconds
Options
I™ Sucress caption I™ Stop audio when dicked
¥ Eailure caption ¥ Pause movie until user clicks
I™ Hint caption [ Double mouse dick
I Show hand cursor over "hit" area ¥ Pause for success/failure captions
OK I Cancel Apply Help
(3 click OK

A Click Box and Failure caption appear on the slide. The Click Box indicates the
area that the user must click before the movie can continue.

O click away from all objects to deselect both the Click Box and the

Failure caption

@ C:\CaptivateData\lesson1

=10l x|

File | Edit View Favorites Tools Help

I

Qe - () - ?‘/'?esaarm ; Fﬂ\ders| 3 (¥ X Z)‘Ev

Please select the
File menu

i Type failure text
here

= g

| ClickBox !
0 (oox100) O
Doz e |

=} O a

5. Reposition the click box.

(J drag the center of the Click Box to an appropriate location on the
slide (do not drag the squares that surround the Click Box unless you

intend to resize the Click Box)
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LR 6. Resize the click box.

/3 [ drag the lower right square of the Click Box up and to
the right to resize it
) File [Fdit

7. Edit the Failure caption. | Q Back -

(J drag the Failure caption to an appropriate location on

your slide
(3 double-click the Failure caption
O replace the text with an B
appropriate message ;:t“;:i‘\irceac':::u"npruperﬁes‘ .J_‘:‘
[ select the text and change the rokes ot ot |
Font to verdana Caption type: Font: Size: |Cn\ﬂ
R captivate red x| [verdana =] Jo =
[ change the Font Size to 10 :ﬁpwt@ﬂlL RS
D C||Ck OK You missed. Please click the File menu.

8. Preview the movie from the current

slide.
D Click the Preview tool and ™ Apply properties to all *failure captions™ in the movie
choose From this slide o | cma | sy | b

9. Test the Failure caption.

O click anywhere except where your placed the click box

The failure caption should appear.

10. Test the Click Box.

[ click where you positioned the click box

The movie continues.

11. Close the Preview.
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Text Entry Boxes

You can use Text Entry Boxes to simulate areas in an application that require a user to
type data. You can instruct users to type specific information into a Text Entry Box and,
depending on what they type, captions can provide feedback on their entry.

Add Text Entry Boxes

1. Open a movie and go to a slide where you wish to add a text entry box.

2. Insert and set Text Entry Box options.

(J choose Insert > Text Entry Box
The New text entry box properties appear.

(O ensure the Text Entry Box tab is selected

O click the Add button

O type This is a text box into the Correct entries area

O if necessary, select Continue from the On success area

(J ensure Infinite attempts is selected from the Allow user area

[ at the bottom of the dialog box, ensure the Current shortcut is Enter
=

Text Entry Box =
Set text entry box properties. 2D )

Text Eniry Box IOphons | Audio | Reporungl

i If the user enters the text correctly
Correct entries: Eont...
Add
Delete
On success: |Cﬂnﬁnue j
Continue: | - I o I
rIf the user enters the textincorrecty
Allow user: 1 = attemptsor [V Infinite attempts
After last attempt: I-: ontinue ﬂ
Continue: I e 550
~Set shortout key
Current shortout: Enter Select keys... I ‘

Ok I Cancel Apply | Help |

3. Set Options for the Text Entry Box.

[ select the Options tab
O if necessary, change the Timing Display for to rest of slide
[J set the Transition to No transition
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(a4 [ deselect all of the remaining options except Success caption,

Failure caption and Pause for success /failure captions
) x|
Options Y
Set text entry box properties. _'_'l;__:’

Text Entry Box  Options |A|.|dio I Reporting |

[ Timing
Display for: |rest of gide 'I 3.3 j seconds
Appear after: 0.0 :Ij seconds
Pause after: 1.5 :Ij seconds
[ Transition
Effect: [No transition =l
I i i P I i e
In: |&.5 =y seconds Qutr j0.5 =y =econds
I~ Apply effect to all “text entry boxes™in the movie
Appearance
Transparency: 0 jl L
~Options
[V Success caption ™ Show button
¥ Failure caption [~ Show text box frame
™ Hint caption [ Password
¥ Pause for sucress/failure captions [~ Case-sensitive
CK I Cancel Apply Help

Three things appear on the slide: the Text Entry Box and two captions, Success and
Failure.

b

Double-click the green caption and replace the text with Great job.
5. Format the Font and Font size as you see fit.

6. Double-click the red caption and replace the text with Sorry, but you need to type
This is a text box.

~

Make the phrase This is a text box bold so that it stands out.

8. Move/resize the Text Entry Box and Success/Failure Captions until the slide looks
good to you.

9. Press [f8] to Preview from this slide.

10. Type This is not a text box into the text field and press [enter].

You should see an error message because you did not type the correct text.
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11. Replace the text you typed with This is a text box and press [enter].

You should see the green caption because you typed the message correctly.
However, the slide hangs around a bit too long after you press [enter]. You will fix
that next.

12. Close the preview.

© 1994-2005, IconlLogic. All Rights Reserved. 11



Building Effective CBTs with Macromedia Captivate

Best Practices for Creating an Effective
“"Let Me Try” movie

[ Keep your movies short—no more than 50-70 slides.

[ Run the Bandwidth Monitor and check your Frame count. The limit of the
Flash Player is 16000 frames (13 minutes of play-time).

[ Use professional quality audio for narrations.

[J Use sans-serif fonts (Verdana) instead of serif fonts (Times New Roman).
[J Hide the Mouse Pointer on all slides that are “Let Me Try.”

[ Set the timing for all Captions to 2 seconds.

[ Add Continue buttons for every Caption with the timing set to 2 seconds
(to match the Captions).

3 Add Click Boxes.

[ Add Highlight Boxes (timing to 2 seconds if they are supposed to synch with
Captions and Click Boxes).

[ Add Text Entry Boxes.

(3 When adding text entry boxes, consider leaving the keystroke as ENTER and
adding a button. Set the properties of the button so that the button is
Transparent. Move the button over the OK button in the dialog box. When a
user interacts with your movie, they will be able to either press ENTER or
click OK.

[0 When adding Text Entry boxes, attempt to use the same font and font size
used in the application you are trying to simulate.

[ If you must use transitions for slide objects, use Fade-In Only. Using the
Fade-In and Out transition leads to inconsistent playback.
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