“Skills and Drills” Learning

Module 5: Triggers and
Hotspots
In This Module You Will Learn About:
•

Triggers, page 88

•

Hotspots, page 103

And You Will Learn To:
•

Delete Default Triggers, page 88

•

Add a Trigger to a Button, page 90

•

Hide Player Buttons, page 92

•

Add Triggers to Layers, page 94

•

Add a Hide Layer Trigger, page 96

•

Add a Slide Trigger, page 98

•

Add a Conditional Trigger, page 99

•

Edit a Trigger, page 101

•

Add a Hotspot and Lightbox Trigger, page 103
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Triggers
Triggers are the key to managing interactivity in your Storyline eLearning courses.
Triggers can be attached to slides or slide objects. They control what happens when a
learner interacts with a slide object or enters or leaves a slide. For instance, in the
Credit Score eCoach you have been building since the beginning of this book, there
are multiple buttons on slide 2.2 of the Your Credit Score scene. During this
module you will add Triggers to each of the buttons that will cause hidden Layers to
appear or disappear. You’ll also add a Continue button that moves the learner to a
different slide, and you’ll create a Trigger that adds a lightbox.

Student Activity: Delete Default Triggers
1. Open TriggerMe from the Storyline2Data folder.
2. Open slide 1.1 Introduction.
The Triggers panel (on the right side of the Storyline window) is where you
manage all of a project’s Triggers. By default, the Triggers panel includes a
few Jump to Triggers that move learners to the next or previous slides.
Because slide 1.1 is the first slide in the scene, you don’t need the Jump to
previous slide Trigger. And the Continue Button on the slide takes the
place of the player’s Jump to next slide Trigger. Because the Triggers on the
Triggers panel aren’t necessary, you’ll delete them.
3. Delete Triggers.

 on the Triggers panel, click the words Slide Triggers
The Jump to next slide Trigger within the Slide Triggers group is selected.

 on the toolbar at the top of the Triggers panel, click Delete the selected
trigger

 click the Yes button to confirm the action
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Deleting Triggers Confidence Check
1. Still working in the TriggerMe project, delete both Player
Triggers from the Triggers panel (Jump to next slide and
Jump to Previous slide) so that only the Continue Button
remains.

2. Save your work.

© 2015, IconLogic, Inc. All Rights Reserved.
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Student Activity: Add a Trigger to a Button
1. Ensure that the TriggerMe project is still open and you’re working on slide
1.1 Introduction.
2. Add a Jump to slide Trigger to a button.

 on the slide, select the Continue button
You can add a Trigger to a button easily via the Triggers panel. The Trigger
can result in any number of actions. For instance, a Trigger can move a
learner to a different slide, open a web page, show or hide a layer, open a
lightbox, or change the state of an object (to name a few).

 on the Triggers panel, click Create a new trigger

The Trigger Wizard opens.






from the Action drop-down menu, ensure Jump to slide is selected
from the Slide drop-down menu, ensure next slide is selected
from the When drop-down menu, ensure User clicks is selected
from the Object drop-down menu, ensure Continue button is selected

Note: While you were asked to select the Continue on the slide prior to
creating the Trigger, pre-selecting an object is not necessary since you
can select any slide object from the Object drop-down menu.

 click the OK button
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3. Preview the scene and test the Trigger.

 click Preview and choose This Scene (you can also press [f12] to preview
a selected scene)

 on the Preview, click the Continue button to jump to the next slide
 on the Welcome slide, click the Prev button to move back to the
Introduction slide

 on the Introduction slide, click the Next button in the lower right of the
slide

Because you deleted the Player Triggers during the last activity, the Prev and
Next buttons don’t do anything. (They’re not necessary anyways because the
Continue button you added is controlling the action.) In this instance, it’s a
good idea to hide the unneeded player buttons from the slide.

 close the Preview
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Student Activity: Hide Player Buttons
1. Ensure that the TriggerMe project is still open and you’re working on slide
1.1 Introduction.
2. Hide Player Buttons.

 on the Slide Layers panel, Base Layer area, click Properties (the Gear
icon shown below)

The Slide Properties dialog box opens.

 from the Slide navigation controls area, deselect Prev and Next

 click the OK button
3. Preview the scene.
4. On the Preview, notice that the Player buttons have been removed from slide
1.1 and the only way to navigate is by clicking the Continue button.
5. Close the Preview.
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Adding Triggers Confidence Check
1. Still working in the TriggerMe project, remove the Player
Next button from slide 1.2.

2. On slide 1.2, add a Trigger to the Continue button that Jumps to the next
slide.
3. Save your work.
4. Close any open slides and return to Story View.
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Student Activity: Add Triggers to Layers
1. Ensure the TriggerMe project is still open.
2. Open slide 2.2 Factors That Affect Your Credit Score.
3. Add a Trigger to a button that displays a hidden layer.

 on slide 2.2, click the Payment History button
 on the Triggers panel, click Create a new trigger
The Trigger Wizard opens.

 from the Action drop-down menu, choose Show layer
 from the Layer drop-down menu, choose Payment History Layer
 from the When drop-down menu, ensure User clicks is selected
 from the Object drop-down menu, ensure Payment History Button is
selected

 click the OK button
4. Preview the slide and click the Payment History button.
The Payment History Layer should appear when the Payment History button is
clicked.
5. Close the Preview.
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Showing Layers Confidence Check
1. Still working in the TriggerMe project, slide 2.2, add
Triggers to the remaining buttons that display their
corresponding layers.
2. Preview the slide and test the Triggers.
Notice that when you click from button to button, the
previous layer automatically hides, which is awesome.
When you’re done clicking the final button, it would be
nice if the last layer hides as well. You’ll take care of that
next by adding a Hide Layer trigger to each layer.
3. Close the Preview.
4. Save your work and close the project.
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Student Activity: Add a Hide Layer Trigger
1. Open HideLayerMe from the Storyline2Data folder.
2. Add a Hide layer trigger to a layer object.

 open slide 2.2
 on the Slide Layers panel, select the Payment History Layer
Notice that a simple object has been added to the layer (and all of the other
layers as well). This object was drawn using an oval shape. (You learned how
to draw shapes on page 61.) You’ll be adding a Trigger to this shape that hides
the open layer.

 select the shape (the circle with the X)
 on the Triggers panel, click Create a new trigger
The Trigger Wizard opens.






from the Action drop-down menu, choose Hide layer
from the Layer drop-down menu, ensure This Layer is selected
from the When drop-down menu, ensure User clicks is selected
from the Object drop-down menu, ensure Oval 1 is selected

 click the OK button
3. Preview the slide and click the Payment History button.
The hidden Payment History Layer should appear.
4. Click the oval object to close the layer.
5. Close the Preview.
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Hide Layers Confidence Check
1. Still working in the HideLayerMe project, slide 2.2, add a
Hide layer trigger to the oval object on the remaining
layers.
2. Preview the slide and test the Triggers.
3. Close the Preview.
4. Save your work.
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Student Activity: Add a Slide Trigger
1. Ensure that the HideLayerMe project is still open and you are working on
side 2.2.
2. On the Slide Layers panel, select the Base Layer.
3. Add a slide Trigger.

 ensure that nothing on slide 2.2 is selected and then, on the Triggers
panel, click Create a new trigger

The Trigger Wizard opens.

 from the Action drop-down menu, choose Change state of
 from the On Object drop-down menu, choose Next Button
 from the To State drop-down menu, choose Hidden
 from the When drop-down menu, ensure that Timeline starts is selected
 from the Object drop-down menu, ensure that 2.2 Factors That Affect
Your Credit Score is selected

 click the OK button
4. Preview the slide and notice that the Next button (typically in the lower right
of the slide) is hidden. Learners will not be able to move forward in the lesson
until they have interacted with every button on the slide. You’ll add a
conditional Trigger that takes that behavior into account.
5. Close the Preview.
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Student Activity: Add a Conditional Trigger
1. Ensure that the HideLayerMe project is still open and you are working on
side 2.2.
2. On the Slide Layers panel, ensure that you are working on the Base Layer.
3. Add a conditional Trigger.

 ensure that nothing on slide 2.2 is selected and then, on the Triggers
panel, click Create a new trigger

The Trigger Wizard opens.

 from the Action drop-down menu, ensure that Change state of is
selected

 from the On Object drop-down menu, choose Next Button





from the To State drop-down menu, ensure that Normal is selected
from the When drop-down menu, choose State
from the On drop-down menu, ensure that All of is selected
from the list beneath All of, select all of the buttons (put a check in each
box)

 ensure that Are is selected from the next drop-down menu
 choose Visited from the final drop-down menu

 click the OK button
© 2015, IconLogic, Inc. All Rights Reserved.
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4. Preview the slide and notice that there isn’t a Next button to take you to the
next slide.
5. Interact with all of the slide buttons. When you’re finished, notice that the
Next button automatically appears on the slide.

6. Close the Preview.
7. Save your work.
8. Close the slide.
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Student Activity: Edit a Trigger
1. Ensure that the HideLayerMe project is still open.
2. Open slide 1.2 (in the Introduction scene).
3. Edit the Continue button’s Trigger so that the learner jumps to the first slide of
a different scene.

 on slide 1.2, select the Continue button
 on the Triggers panel, click Edit the selected trigger

The Trigger Wizard opens.






from the Action drop-down menu choose Jump to slide
from the Slide drop-down menu, choose 2.1 Calculate Your Possible...
from the When drop-down menu, ensure User clicks is selected
from the Object drop-down menu, ensure Button 1 is selected

 click the OK button
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4. Preview the Entire Project.

5. Click the button on slide 1.1 to go to slide 1.2. Once you’re on slide 1.2,
clicking Continue takes you to the next scene, slide 2.1.
6. Close the Preview.
7. Save your work.
8. Close the slide.
9. Close the project.

102

© 2015, IconLogic, Inc. All Rights Reserved.

Module 5: Triggers and Hotspots > Hotspots > Add a Hotspot and Lightbox Trigger

Hotspots
Hotspots are areas of a slide that can be made interactive. You can draw a Hotspot
on top of anything that you can see on any slide. Once you’ve created the Hotspot,
you can easily add Triggers to initiate the interactivity.

Student Activity: Add a Hotspot and Lightbox Trigger
1. Open LightBoxMe from the Storyline2Data folder.
2. Open slide 4.1 Credit Score Estimator.
3. Insert an image.






select the Insert tab on the Ribbon
from the Illustrations group, click Picture
from the Storyline2Data folder, open the images_animation folder
open credit-score-estimator

4. Resize the image until your slide is similar to the image below.

In a moment you’ll be adding a Lightbox Trigger to a hotspot. A Lightbox is
typically used to display an existing slide in a pop-up window.
5. Close the slide.
6. Open slide 2.4 Credit Score Resources.
7. Add a Hotspot over a slide object.

 click the Insert tab on the Ribbon
 from the Interactive Objects group, click Controls
© 2015, IconLogic, Inc. All Rights Reserved.
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 from the Hotspots area, select the Rectangle hotspot

 on slide 2.4, draw a hotspot over the words “Check out this credit
estimator resource”

8. Add a Lightbox Trigger to the Hotspot.

 ensure that the Hotspot is selected and, on the Triggers panel, click
Create a new trigger

The Trigger Wizard opens.

 from the Action drop-down menu choose Lightbox slide
 from the Slide drop-down menu, choose 4.1 Credit Score Estimator
 from the When drop-down menu, ensure User clicks is selected
 from the Object drop-down menu, ensure Hotspot 1 is selected

 click the OK button
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9. Preview the Entire Project.
10. Use the Menu at the left to go to the Credit Score Resources slide.
Note: If Credit Score Resources does not appear in the menu, close
the Preview. Select the Home tab on the Ribbon and, from the Publish
group, click Player. Select the Menu tab and, from the bottom of the
Menu, click Reset from Story. Click the OK button to close the Player
Properties. Preview the project again and use the Menu at the left to go
to the Credit Score Resources.

11. Click the Hotspot you drew over the text to open the Lightbox slide.

12. Close the Lightbox slide.
13. Close the Preview.
14. Close the slide.
15. Save and close the project.
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Notes
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