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About This Book
About the Author
Kevin A. Siegel is the founder and president of IconLogic, Inc. He has
written more than 100 step-by-step computer training books, including
Essentials of Adobe Captivate 4, Essentials of Adobe Captivate 3,
Essentials of Adobe Captivate 2, Essentials of Macromedia Captivate,
Essentials of RoboDemo 5, Essentials of RoboDemo 4, Essentials of
RoboDemo 3, Essentials of Adobe RoboHelp 8 HTML, Essentials of Adobe
RoboHelp 7 HTML, Essentials of Adobe Dreamweaver CS3, QuarkXPress
8: The Basics, QuarkXPress 8: Beyond the Basics, Essentials of
QuarkXPress 7, Accelerated QuarkXPress 6 and Essentials of Adobe
InDesign CS3.
Kevin spent five years in the U.S. Coast Guard as an award-winning
photojournalist and has more than 23 years experience as a print
publisher and technical writer. He is a certified technical trainer, has
been a classroom instructor for more than 16 years and is a frequent
speaker at trade shows and conventions. Kevin holds multiple
certifications from companies such as Adobe and the CompTIA. You can
reach Kevin at ksiegel@iconlogic.com.

About IconLogic Books
IconLogic books are unique! They are created by instructors with years
of software training experience. Before IconLogic books, our instructors
rarely found a book that was perfect for a classroom setting. If the book
was beautiful, odds were that the text was too small to read and hard to
follow. If the text in a book was the right size, the quality of exercises
left something to be desired.
Finally tiring of using inadequate materials, our instructors started
teaching without any books at all. Over the years, we’ve had many
students ask if the in-class instruction came from a book. If so, they said
they’d buy the book. That sparked an idea. We asked students — just
like you—what they wanted in a training manual. You responded, and
the results appear in this book.
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We hope you enjoy the book. If you have any comments or questions, please see
page viii for our contact information.

Book Conventions
This book has been divided into several modules. Since each module builds on
lessons learned in a previous module, we recommend that you complete each
module in succession. During every module, you will be guided through lessons step
by step. Instructions for you to follow will look like this:

 instructions for you to follow will look like this
If you are expected to type anything or if something is important, it will be set in
bold type like this:

 type 9 in the box
If you are expected to press a key on your keyboard, the key will be in brackets like
this:

 press [ctrl]

Confidence Check
You will also come across the little guy at the right. He indicates
a Confidence Check. Throughout each module you will be guided
through hands-on exercises. But at some point you’ll have to
fend for yourself. That is where Confidence Checks come in.
They’re very important. You must be sure to complete each of
them because some exercises build on completed Confidence
Checks.

System Requirements
To complete the lessons presented in this book, you will need the following software
and hardware: Adobe Captivate 4, Intel Pentium 4, Intel Centrino, Intel Xeon, or
Intel Core Duo (or compatible) processor; Microsoft Windows XP with Service Pack 2
(Service Pack 3 recommended) or Windows Vista Home Premium, Business,
Ultimate, or Enterprise with Service Pack 1 (certified for 32-bit editions); 512MB of
RAM (1GB recommended); 1.5GB of available hard-disk space; additional free space
required during installation (cannot install on flash-based storage devices); DVDROM drive; 800x600 screen resolution (1,024x768 recommended).
The Adobe Captivate 4 software does not come with this book. The software can be
purchased directly from Adobe (www.adobe.com). You can also download a trial
version of Captivate from Adobe. There are no limitations on the trial and it will last
for 30 days from the day you install it on your computer.
You will also need Microsoft PowerPoint installed on your computer. If PowerPoint is
not installed, you will not be able to import PowerPoint presentations into Captivate
(which you will learn to do during the activities that begin on page 26).
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Data Files
The data files that support the lessons presented in this book can be downloaded
from the IconLogic Web site. Instructions for downloading the data files appear
below.

Student Activity: Download Data Files From the Web
1. Download the student data files necessary to complete the lessons presented in
this book.

 start a Web browser
 go to the following Web address: http://www.iconlogic.com
 click the Data Files for IconLogic Workbooks link

 click the PC link
 find and click the Captivate 4, Beyond the Essentials link
A dialog box will appear asking if you want to Save or Open the data files.

 click Save
 navigate to your desktop
 click Save
2. After the file downloads, close your Web browser.
3. Extract the data files.

 find the Captivate4_BeyondEssentialsData.exe file you just downloaded
to your desktop

 double-click the file to open it
The WinZip Self-Extractor appears.

 confirm C:\ appears in the Unzip to folder area
 click Unzip
Several files will be extracted.

 click OK
 click Close
The data files are now on your hard drive. As you move through the lessons in
this book, you will be working with these files. When you have completed the
lessons in this book, you can delete both the data folder (on the C drive) and the
Captivate4_BeyondEssentialsData.exe you downloaded to your desktop.
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Need More Books?
We are proud to offer books on the following subjects:

Editing & Grammar
Abrams’ Guide to Grammar: Second Edition
Editing With MS Word 2007

Graphics and Multimedia Tools
Captivate versions 1 through 4
Flash Basic 8
PowerPoint versions 4 through 2002

Help Authoring
Captivate versions 1 through 4
Adobe RoboHelp HTML 6 through 8

Print Publishing (Page Layout)
InDesign CS2 through CS3
QuarkXPress versions 6 through 8

Web Page Design and Development
Dreamweaver versions MX 2004 through CS3
and there are more coming all the time.

To order, contact
IconLogic, Inc.
3320 Breckenridge Way | Riva, MD 21140 | 410.956.4949
Web: www.iconlogic.com | E-mail: iconlogic@iconlogic.com

Special Thanks
I’d like to thank Tim Lucas, John Daigle, Rick Stone, Joyce Nolan, Lorraine Smith,
Kim Wendkos, AJ Barker, Barbara Ash and Janet Tonner for their hard work and
support during the production of this book.
~ Kevin A. Siegel
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Module 7: Project and
Design Templates
In This Module You Will Learn To
•

Create a Project Template

•

Create a Project From a Template

•

Record Additional Slides

•

Delete Unused Objects

•

Create a Mask

•

Add a Text Animation Placeholder

•

Create a Design Template

•

Format Design Template Objects

•

Apply a Design Template to a Project
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Project Templates
If you want to take the best components of any Captivate project and use them over
and over, you can save any of your existing Captivate projects as a project
template. The next time you create a project, you can use the project template and
quickly produce a new project that contains those “best in class” components from
the template.
A good project template will contain, at the very least:

 An introduction slide
 A conclusion slide
 A customized skin
 Document Info
 Variables, widgets and actions as appropriate
 Project Start and End settings

Student Activity: Create a Project Template
1. Open TemplateMe from the Captivate4_BeyondEssentialsData folder.
This is a 10-slide project that has already been approved by management.
Since management would like you to use this project as the basis of all
projects you record in the future, you’ll make the necessary changes to the
project to make it a project template.
2. Delete unnecessary slides.

 ensure you are in Storyboard View
 click one time on Slide 2
 press [Shift] on your keyboard and click one time on Slide 9
Slides 2 through 9 should all be selected.

 release the [Shift] key
 press [delete]
A confirmation box appears.

 click Yes
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Project and Design Templates > Project Templates > Create a Project Template
3. Delete the audio from Slide 1.

 click the audio badge beneath Slide 1

 click Remove

 click Yes
4. Save the project as a Project Template.

 choose File > Save As
 choose Adobe Captivate Templates (*.cptl) from the Save as type
drop-down menu

 navigate to the Captivate4_BeyondEssentialsData folder
 change the File name to My First Captivate Template
 click the Save button
Notice that the project name that appears in the title bar now includes the
CPTL extension of a project template.

5. Close My First Captivate Template.
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Student Activity: Create a Project From a Template
1. Minimize Captivate.
2. Using Windows Explorer, navigate to the
Captivate4_BeyondEssentialsData folder
3. Open the RecordingStage folder.
If necessary, create a new folder inside the RecordingStage folder window
(File > New > Folder).

4. Return to Captivate.
5. Create a new project that uses a project template.

 from the Create Project area on the Welcome screen, click From Template

The Open dialog box appears.

 open My First Captivate Template.cptl from the
Captivate4_BeyondEssentialsData folder
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Project and Design Templates > Project Templates > Create a Project From a Template
The project opens and you are alerted about unused items. You will deal with
that later.

 click OK
Notice that the new project is untitled, even though you opened the template.
Notice also that the project’s name contains a CP extension, indicating that it
is a Captivate project, not a template.
Other than the file name extension, your new project is identical to the
template you created in every way and it has all of the settings of the
template.
6. Save the project to the Captivate4_BeyondEssentialsData folder as Testing
My Template. Keep the project open for the next activity.

© 1994-2009, IconLogic, Inc. All Rights Reserved.
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Student Activity: Record Additional Slides
1. The Testing My Template project should still be open.
2. Record additional slides to the project.

 choose Insert > Recording Slide
The Record additional slides dialog box appears.

 if necessary, select Record slides and insert after the slide
selected below

 select Slide 1 - Begin Lesson
 select RecordingStage from the Select Application drop-down menu
 ensure Snap To Window is selected

 click OK
The red recording area appears with the control panel at the left.
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Project and Design Templates > Project Templates > Record Additional Slides
3. Set the recording options.

 click the Select Automatic Recording Mode button
control panel

on the

The Automatic Recording panel appears.

 ensure Panning is set to No Panning
 ensure Audio is set to No Narration
 select Custom from the Mode drop-down menu






click the Settings button
from the Recording category, select Mode(s)
select Custom from the Mode drop-down menu
ensure your settings match the picture below

 click OK
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4. Record the simulation.







click the Record button
select the folder inside the RecordingStage window
choose File
choose Delete
click Yes

5. End the recording.

 press [end] on your keyboard
You should automatically be returned to the Captivate project; there should
now be seven or eight slides in the project.
6. Close the project. There is no need to save it.
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Student Activity: Delete Unused Objects
1. Open a template.

 choose File > Open
 select Adobe Captivate Templates (*cptl) from the Files of type dropdown menu

 open My First Captivate Template.cptl
You are again alerted about unused items. You will deal with that pesky
message now.

 click OK
2. Open Slide 1.
3. Show the Library.

 choose Window > Library
Most of the images and all of the audio files in the Library were being used in
the project that you opened when you created the template. They are no
longer being used and are not necessary.

© 1994-2009, IconLogic, Inc. All Rights Reserved.
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4. Remove unused Library items.

 select the Select Unused Items button

on the Library

Note: If you don’t see the Select Unused Items button at the top of the
Library, you may need to stretch the Library panel wider.

 press [delete] on your keyboard

 click Yes to the Confirmation dialog box
There is still a Visual Mouse Click that isn’t necessary and can be deleted.

 select the VisualClick object from the bottom of the Library
 press [delete] on your keyboard
 click Yes to the Confirmation dialog box
5. Close the Library.
6. Save the template (keep it open for the next activity).
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Student Activity: Create a Mask
1. The My First Captivate Template.cptl project template should still be open.
2. Create a mask on Slide 1.






Go to Slide 1
choose Insert > Image
from the Images folder, open WhiteBox.bmp
move and resize the white box image until it completely covers the Lesson
1: Creating New Folders area of the slide background

 right-click the white box image and choose Merge into Background
 click Yes when prompted

3. Save the template.
Keep the template open for the next activity.
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Template Placeholders
You can add any object to a template’s slide including text captions, buttons, click
boxes and highlight boxes. When you add a text caption, a typical process would be
to insert some default (or placeholder) text within the text caption. Developers who
create projects using your template would be expected to replace the placeholder
text with actual text. At least, you would assume that your developer would replace
text, such as “Replace this text with real text” with real text. However, if your
developer misses the placeholder text, the project will publish with any placeholder
text that is not actually replaced.
Which brings me to actual Placeholders that you can add to any slide within the
template. Unlike actual objects, Placeholders do not preview or publish if they are not
populated with actual content.
You can add Placeholders for any of the following:








Images
Text Captions
Rollover Images and/or Captions
Flash Video, Text Animation and Animation
Recording Slides
Question Slides

Student Activity: Add a Text Animation Placeholder
1. The My First Captivate Template.cptl project template should still be open.
2. Insert a Text Animation Placeholder.

 on Slide 1, choose Insert > Placeholder > Text Animation
 on the Text Animation Placeholder tab, select
any Effect you like from the Effect drop-down menu

 click the Change font button
 change the Font to Verdana and the Size to 36
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 click OK to close the Font dialog box (the New Text Animation Placeholder
dialog box should still be open)

 select the Options tab
 select rest of slide from the Display for drop-down menu
 select Fade in only from the Transition Effect drop-down menu

 click OK
Position the Placeholder as shown below.

3. Save your work.
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Confidence Check
1. Still working in the My First Captivate Template project
template, select Slide 1 and then insert a Recording Slide
placeholder.

2. Save and close the template.
3. Create a new project from the My First Captivate Template project
template.
When the template is accessed this time, the first thing you should notice is
that you are not alerted about unused items.
4. Open Slide 1.
5. Double-click the Sample Text Animation placeholder.
6. Change the words Sample Text with the phrase Testing a Placeholder and
click OK.
7. Press [F4] to preview the project and you’ll see your new text animation.
8. Close the preview.
9. Go to Slide 2 and double-click the Recording Slide Placeholder.
The Record slides for placeholder
dialog box appears. If you moved
forward and clicked OK, you could
record new slides that would be added
to the project.
10. Click Cancel.
11. Close the project (there is no need
to save it).
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Design Templates
As you learned beginning on page 114, Project Templates are perfect for ensuring
consistency for all new projects. When you base a new project on a template, specific
properties of the new project will be pre-determined (such as the recording size, skin
used, number of default slides, etc.). However, changes made to the template down
the road will have no bearing on projects based on the template (there is no link
between the template and its projects).
Design Templates allow you to ensure consistency of objects in existing projects. For
instance, you can set up the appearance of highlight boxes in a Design Template and
apply those attributes to existing Captivate projects (just in case a rogue developer
has decided to use their own colors in their highlight boxes).

Student Activity: Create a Design Template
1. Create a new Design template.

 on the Captivate Welcome screen, click Design Template from the
Create Template area

An untitled template is created (named untitled.cpdt). The template contains
seven slides.
2. Save the Design template to the Captivate4_BeyondEssentialsData folder as
yourfirstnameDesignTemplate.
3. Explore the slides in the Design template.

 move from slide to slide and notice that just about every object you can
add to a Captivate slide is represented in the template

4. Explore the menus in the Design template.

 open the menus (File, Edit, View, etc.)
Notice that the menu items are much more limited here than in a typical
Captivate project. In addition, you cannot insert any objects such as
animations or text captions (there isn’t even an Insert menu). And there isn’t
a Timeline or Library window. At first glance, there doesn’t appear to be much
you can do at all with this pesky template.
Ah, but looks can be deceiving. The goal for working effectively with a Design
template is to make objects in the template look the way you want. After that,
it’s a simple matter of applying the Design template to your existing projects.
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Student Activity: Format Design Template Objects
1. Your Design template should be open.
2. Format the appearance of highlight boxes within the Design template.

 go to Slide 5 of the template
There is a sample highlight box on the slide.

 right-click the highlight box and choose Properties
 change the Frame color to orange
 change the Frame width to 2
 change the Fill color to orange
 change the Fill transparency to 82

 click OK
3. Save your work.

128

© 1994-2009, IconLogic, Inc. All Rights Reserved.

Project and Design Templates > Design Templates > Format Design Template Objects
4. Format the appearance of text captions within the Design template.

 go to Slide 1 of the template
There is a sample text caption on the slide. It’s transparent and using a
specific font, size and color.







right-click the Text Caption and choose Properties
change the Caption type to adobe blue
change the Font to Verdana
change the Size to 10
change the Font color to Black

 click OK

5. Save your work.
6. Close the template.
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Student Activity: Apply a Design Template to a Project
1. Open FixMe from the Captivate4_BeyondEssentialsData folder.
2. Explore the project for problems.

 open Slide 2
The Caption Type and Font size aren’t correct.

 go to Slide 3
The appearance of the highlight box isn’t correct either. In fact, if you scroll
through the project, you’ll notice that none of the text captions or highlight
boxes are formatted to corporate standards (specifically, both text captions
and highlight boxes were supposed to use the formatting specified in the
Design Template).
In addition to the problems mentioned above, you’ll see that there are
“issues” in this project that go beyond an incorrect choice of caption type and
highlight box colors. For instance, slides 1 and 2 contain buttons using a font
that is, at best, hard to read. The failure captions on those slides with click
boxes are also problematic (they’re using strange fonts as well).
3. Apply the Design template to the project.

 choose Window > Design Template
The Design template panel appears at the right of your window.

 click the Browse Template button
Design Template panel)

(located at the bottom of the

 open the Captivate4_BeyondEssentialsData folder
 open the Design template you created earlier
Your template appears in the Available Templates list.

 click Apply All from beneath your template
The attributes of the objects in your template are applied to the slide objects
in your project.
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4. Explore the project to confirm that changes have been made.

 go to Slide 2
The Caption Type and Font size now match those you specified in the
template.

 go to Slide 3
The appearance of the highlight box has been fixed as well.
Just as interesting as the changes that you might have been expecting in the
FixMe project, notice that the font used in the buttons (on Slides 1 and 2), and
the failure captions throughout the project have all been updated. While the
appearance has been changed, the font used in those objects is Arial, the
default font used in the Design template. Since you did not update those
objects, the default template properties for all of the template’s objects have
been applied to all of the objects in the FixMe project. In the future, it would
be a good idea to set all of the properties of a Design template object prior to
applying the template to a project.
5. Save your work and close the project.

Confidence Check
1. Open your Design template (File > Open).
2. Go to Slide 3.
3. Show the Properties of the failure caption and change the
Font attributes to Verdana 10.
4.

Go to Slide 4.

5. Show the Properties of the button and change the Font
attributes to Verdana 10.
6. Go through the rest of the template making changes as you see fit (generally
speaking, the Font attributes of the objects should be Verdana 10.
7. Save and close the template.
8. Open the FixMe project.
9. On Slide 1, notice that the button’s Font attributes have not been updated,
even though you updated the template.
10. Go to Slide 3 and notice that the Font attributes in the failure caption have not
been updated.
While it might seem that the template isn’t working, keep in mind that there
isn’t a live link between the project and its template. If you want the changes
to appear in the project, you’ll need to reapply the Design template.
11. Apply your Design template to all of the slides in your project.
12. Scroll through your slides and notice that the buttons and failure captions
have updated and now match the formatting from your template.
13. Save and close the project.

© 1994-2009, IconLogic, Inc. All Rights Reserved.

131

Adobe Captivate 4: Beyond the Essentials

132

© 1994-2009, IconLogic, Inc. All Rights Reserved.

ISBN 1-932733-29-9

53500

9 781932 733297
Adobe Captivate 4: Beyond The Essentials

