Module 7: Focus, Markers, TOCs and Hotspots

In This Module You Will Learn About:

- Hide and Show the Cursor, page 118
- Focus, page 120
- SmartFocus, page 124
- Markers, page 126
- TOCs, page 128
- Hotspots, page 136

And You Will Learn To:

- Control Mouse Visibility, page 118
- Add a Zoom-n-Pan, page 120
- Add a Zoom-n-Pan Keyframe, page 122
- Apply SmartFocus, page 124
- Add a Marker, page 126
- Add a TOC, page 128
- Customize a TOC, page 131
- Replace a Background Image, page 136
- Add a Transparent Hotspot, page 137
- Set Flash Hotspot Properties, page 138
Hide and Show the Cursor

If you recorded your video and elected to include the cursor, and you selected **Ensure the cursor effects will be editable during production** (see page 34), you can change the cursor effects (you learned how on page 55). Cool stuff. However, you can also elect to hide the mouse cursor at any time and, using keyframes, bring the cursor back (without having to rerecord your video).

**Student Activity: Control Mouse Visibility**

1. Using Camtasia Studio 7, open **HideMyMouse.camproj** from the Camtasia7Data folder.

2. Preview part of the video.
   - On the Timeline, double-click the **renamefoldervideo_Screen** to move the Playhead to the 1:25;10 mark of the video
   - Choose **Play > Play** to play the video from the current position

   At approximately the **1:34** mark, notice in the video that the folder is being renamed. Nice. But there is an insertion point when the folder is being renamed and a mouse cursor on the screen at the same time. You are about to hide the mouse cursor for the remainder of the video.

3. Add a keyframe.
   - Ensure the Playhead is positioned at approximately the **1:34** mark on the Timeline (again, this is where the folder in the video is being renamed and you want to hide the mouse cursor)
   - Choose **Tools > Cursor effects**
   - Click the **Add keyframe** button

   Keyframes are used when you want something to change onscreen. Currently the mouse is visible throughout your video. You’d like to hide the mouse from the 1:34 mark of the video on. At some point, you’ll want it back. If you think of a keyframe as a light switch in your home, you’d need a keyframe to turn the lights off and another to turn the lights back on (otherwise, the lights aren’t coming back on).

   The keyframe you just added appears on your Timeline as a red diamond on the Cursor Track.
4. Hide the mouse cursor.
   - deselect **Mouse cursor visible** (remove the check mark)
   
   In the Preview window, notice that the mouse pointer is gone. It’s that simple.

5. Preview part of the video.
   - on the Timeline, double-click the **renamefoldervideo_Screen** to move the Playhead to the 1:25;10 mark of the video
   
   Notice that at this part of the video, the mouse is visible.
   - choose **Play > Play** to play the video from the current position

   At approximately the **1:34** mark, notice that the mouse cursor goes away. **How cool is that?** Of course, if you continue to watch the video, you’ll notice that the poor mouse cursor does not know to reappear during the next section (when the **deleterestorevideo_Screen avi** begins to play). Next you’ll add a second keyframe and allow the mouse to reappear.

6. Add another keyframe.
   - on the Timeline, double-click the **deleterestorevideo_Screen avi** to move the Playhead to the **2:12;02** portion of the video
   - if necessary, choose **Tools > Cursor effects** to display the Cursor effects panel
   - click the **Add keyframe** button

7. Show the cursor.
   - select **Mouse cursor visible** (put the check mark back)
   
   In the Preview window, notice that the mouse pointer has reappeared.

8. Save your work.

9. Preview the changes.
   - on the Timeline, double-click the **renamefoldervideo_Screen** to move the Playhead back to the 1:25;10 mark of the video
   - choose **Play > Play** to play the video from the current position

   As the video plays, notice that the mouse cursor goes away and then reappears during the last part of the video.
Focus
Camtasia has two really cool features that help you keep the focus of the lesson where you want it. You can automatically create focus on an important area of the screen for the learner by zooming closer to the action using Zoom-n-pan and SmartFocus. You will learn these features over the next few activities.

Zoom-n-Pan
The Zoom-n-pan feature is useful if you have recorded a large window (i.e., 1024x768), but you still want to focus the customer on a specific area of the screen. You learned how Highlight Rectangles can grab the learner’s attention on page 77. However, Highlight Rectangles cannot get your customer closer to the action. In fact, if you recorded a large screen size, the action taking place on your screen (a tool being selected, for instance) might simply be too small to be easily noticed by your learner. By automatically zooming and panning closer to the action on the screen, you can ensure the focus of your video is exactly where you want it without the need to re-record the video.

Student Activity: Add a Zoom-n-Pan

1. Using Camtasia Studio 7, open ZoomMe.camproj from the Camtasia7Data folder.

2. Preview a part of the video where you will add a Zoom-n-pan.
   - on the Timeline, double-click the deleterestorevideo_Screen avi to move the Playhead to the 2:12;02 portion of the video
   - click the Play button on the Preview panel to play the video from the 2:12;02 mark

   At approximately the 2:26 mark of the preview, the narrator is discussing the Recycle Bin and how it fills with crumpled paper. At this point in the video, it would be really cool if the video automatically moved to the Recycle Bin (panned) and then zoomed closer. It would be even nicer if, after a few seconds, the video automatically zoomed back out.

3. Add a Zoom-n-pan mark.
   - on the Timeline, position the Playhead at approximately the 2:27 mark
   - choose Tools > Zoom-n-pan

   The Zoom-n-pan Properties appear. Notice that there is a box around the entire preview at the left. If left alone, there won’t be any zoom or pan effect applied to the video since you haven’t yet told Camtasia where you’d like to pan and then zoom.

   - drag the lower left resizing handle up and to the right until the border is similar to the picture at the right
The entire Preview area should look similar to the picture below.

On the Timeline, notice that a new track has made an appearance—the Zoom track. The blue diamond on the Zoom track is the Pan effect you just added.

4. Preview the Zoom-n-pan.
   - on the Timeline, position the Playhead just to the left of the blue diamond
   - on the Preview panel, click the Play button

The Zoom-n-pan effect is cool. However, because there are callouts describing other events occurring onscreen that you can no longer see, it might be better if the effect happens a little later. You can control this and other Zoom-n-pan options easily enough, which you will do next.

5. Save your work.
Student Activity: Add a Zoom-n-Pan Keyframe

1. The **ZoomMe** project should still be open.

2. Add a keyframe to the Zoom-n-pan.
   - on the Timeline, position the Playhead at approximately the **2:31** mark
   - At this part of the video, the learner has been zoomed closer to the Recycle Bin. This would be a perfect place to zoom back out.
   - ensure the **Zoom-n-pan** panel is open (Tools menu)
   - click the **Add keyframe** button

   ![Add keyframe button]

   On the Timeline, notice that there is a second blue diamond on the Zoom Track.

3. Zoom back out.
   - drag the lower left resizing handle **down** and to the **left** until the border is similar to the picture below

   ![Zoom-n-pan panel with resized border]
The entire Preview area should look similar to the picture below.

4. Preview the changes.
   - on the Timeline, position the Playhead just to the left of the first blue diamond
   - on the Preview panel, click the **Play** button

      The Zoom-n-pan should occur twice. The first time you’ll zoom in and then, a few seconds later, you’ll zoom back out! Coolness!

5. Save your work.

**Confidence Check**

1. On the Timeline, double-click the first blue diamond to display the Zoom-n-pan Properties.
2. Change the Scale to **250%**.
3. Drag the Duration slider right until you get to **2.00** sec.

4. On the Timeline, position the Playhead just to the left of the first blue diamond
5. On the Preview panel, click the **Play** button.

      The Zoom-n-pan shouldn’t be quite as close this time and the actual zoom should be a bit slower than before.

6. Save your work.
SmartFocus

You learned about the Zoom-n-pan feature on page 120. While easy to use, the Zoom-n-pan feature does require you to set both the zoom in and zoom out keyframes. Wouldn’t it be great if Camtasia was able to automatically zoom closer to the screen based on mouse actions or typing that was recorded in a video? Say hello to SmartFocus. This feature is especially useful if you have recorded a large window (i.e., 1024x768) and you want to produce a Web video at a smaller size (i.e., 640x480). SmartFocus will automatically detect mouse clicks and typing and automatically create the Zoom-n-pan keyframes. I know that I described the Zoom-n-pan feature as “coolness” a few pages back, but SmartFocus is even cooler. *Is there such a word as “uber-coolness?”* If so, let’s go with that when thinking about the possibilities using SmartFocus.

Student Activity: Apply SmartFocus

1. Create a new project.
   - using Camtasia Studio, choose **File > New project** (you can save the ZoomMe project from the last activity if prompted)

2. Import a video.
   - choose **File > Import media**
   - from the Camtasia7Data/Camrec folder, open *GoogleLangRecording.camrec*

   The imported video appears on the Clip Bin.

3. Add a video to the Timeline.
   - right-click the *GoogleLangRecording* in the Clip Bin and choose **Add to timeline**

   The Editing Dimensions dialog box appears. As mentioned earlier, the size of the video you imported is 1024x768. It’s no problem resizing a video that large down to 640x480, although things might get just a bit too small and hard to read. Let’s see if that’s the case.

   - ensure **640 x 480** is selected in the drop-down menu
   - ensure **Keep aspect ratio** is selected
☐ click the **OK** button

Check out the Timeline. Notice that five Zoom-n-pan keyframes have automatically been added for you.

![Timeline with keyframes](image)

4. Preview the video.

☐ press **[Ctrl]** **[Shift]** **[Spacebar]** on your keyboard to Preview the entire video

   The video starts out too small (because you resized a large video down to 640x480). But check out what happens when the typing occurs. That’s right, Camtasia has automatically added the Zoom-n-pan effect... *uber-coolness*!

**Confidence Check**

1. On the Timeline, double-click the third blue diamond to open the Zoom-n-pan Properties.

2. Stretch the zoom area taller so that the top of the menu in the video will be visible.

![Zoom-n-pan Properties](image)

3. Click the **Advanced** button near the bottom of the panel.

4. Drag the Tilt slider right to the fourth tick mark.

![Tilt slider](image)

5. On the Timeline, position the Playhead just to the left of the third keyframe and then preview the video. Thanks to the Tilt feature you just added, the video should tilt quite a bit and then return to its original position. That’s one nifty special effect should you ever need it.

6. Save the project to the Camtasia7Data folder as **MySmartFocus_Tilt**.
Markers

Markers create navigation points within a video. When you add a TOC (you will learn about TOCs on page 128) to your finished lesson, the markers you add can be used to create hyperlinks (jumps) throughout the lesson. When you allow your customers to jump around the lesson it’s referred to as branching.

Student Activity: Add a Marker

1. Using Camtasia Studio 7, open MarkMe_TOCMe.camproj from the Camtasia7Data folder.

2. Add a Marker.
   - click anywhere on the Timeline
   - press the [Home] key on your keyboard to move the Playhead to the very beginning of the video

On the Video 1 Track, notice that there is a Title Clip before the transition into the first lesson (you might need to zoom closer to the Timeline to see the Timeline objects clearly). This is where you are going to add your first marker.

   - right-click the Marker Track (the space just beneath the Playhead) and choose Add a marker

The Marker Name dialog box appears. Since you will be using the markers you create on a TOC, the names you give the markers should be descriptive (if appropriate) and be written as you’d want them to appear on the TOC.

   - type Home into the text field

   - click the OK button

The marker will appear in the Markers Track as a green diamond.
Confidence Check

1. Still working in the MarkMe_TOCMe project, position the Playhead on the Timeline at the second Title Clip (where the first lesson begins).

2. Add a new marker named Lesson 1: Creating New Folders.

3. Position the Playhead on the Timeline at the Title Clip where the second lesson begins.

4. Add a new marker named Lesson 2: Renaming Folders.

5. Position the Playhead on the Timeline at the Title Clip where the third lesson begins.

6. Add a new marker named Lesson 3: Restoring.

Your project should now contain four markers.

7. Save your work.
TOCs

If you'd like to allow your customers to control the learning experience and navigate (branch) through your lesson in any order they'd like, you can add a TOC to your video during the Production process. The process of adding a TOC begins with adding markers to your project (as you learned to do on page 126). When you add the TOC, you can elect to use the marker names as the hyperlinks on your TOC, or make up new names on the fly.

Note: Before attempting to work with a TOC, you must first complete the “Markers” activity that begins on page 126.

Student Activity: Add a TOC

1. The MarkMe_TOCMMe project should still be open.

2. Produce and share using Custom production settings.
   - choose File > Produce and share (or press [Ctrl] [p])
   - select Custom production settings from the drop-down menu

3. Select the output format.
   - if necessary, select MP4/FLV/SWF - Flash outputs and then click the Next button
   
   The Flash Templates dialog box opens. (If you are using Camtasia 7.1, the dialog box is labelled Flash Controllers).

4. Select an Appearance Template.
   - from the Template drop-down menu, select ExpressShow with TOC
     (If you are using Camtasia 7.1, choose ExpressShow from the Controller drop-down menu)

   - ensure the Theme is set to Black

   Camtasia 7 shown above, left. Camtasia 7.1 shown above right.

   - click the Next button
5. Disable the Watermark.

- from the Watermark area, deselect **Include watermark**

6. Create a Web page with the video.

- from the HTML area of the Video Options dialog box, select **Embed video into HTML**

7. Produce the video.

- click the **Next** button

- click the **Finish** button

Your video will be rendered—depending on the processing power of your computer, it could take a few minutes to complete.

8. Watch the finished video.

- click the **Play** button to start the video

Look at that... a TOC appears at the left of the video and your markers appear, just like magic. The TOC works (you can click the marker text to prove that). However, you’ll notice that the marker titles are so long they didn’t fit. You’ll fix that soon.
9. Review the published files.
   - close the browser window
   - click the **Open production folder** button on the Production Results dialog box

The published files appear. If you wanted to upload this lesson to your Web server, be sure to post all of these files. When creating a link that will start the lesson, link to the HTML file (in this case, MarkMe_TOCMe.html). Once the HTML file opens in the Web browser, the remaining files will open and your lesson will play.

- close the MarkMe_TOCMe window

10. Back in Camtasia, click the **Finish** button (leave the MarkMe_TOCMe project open).

11. Save your work.
Student Activity: Customize a TOC

1. The MarkMe_TOCMe project should still be open.

2. Change the Dimensions of the TOC.
   - select **File > Produce and share**
   - if necessary, select **Custom production settings** from the drop-down menu
   - click the **Next** button
   - if necessary, select **MP4/FLV/SWF - Flash outputs**
   - click the **Next** button
   - if necessary, select **ExpressShow with TOC** from the Template drop-down menu (If you are using Camtasia 7.1, choose **ExpressShow**.)

   - if you are using Camtasia 7, click the **Change dimensions** button
   - if you are using Camtasia 7.1, choose **Custom** from the Video Size drop-down menu

The Video Dimensions - Preview screen opens.

   - at the bottom of the screen, select the **Custom** radio button
   - change the TOC width to **212**

   - press `[Tab]` on your keyboard

Notice that the new width is just wide enough to display your marker titles on the TOC.

   - click the **OK** button
3. Change the Flash Options so that you produce a SWF.

☐ if you are using Camtasia 7.1, choose SWF from the File format dropdown menu; if you are using version 7.0, click the Flash options button and, on the Video tab, change the Format to SWF.

You might find yourself in a debate as to what the SWF suffix stands for. Years ago I was told that SWF stood for “Shockwave File.” In reality, the suffix once stood for “Shockwave Flash.” The name was often confused with Macromedia’s Shockwave format used for a program called Macromedia Director (that program lives today as Adobe Director). To end the confusion, Macromedia decided that SWF would forevermore stand for “Small Web Format.”

4. Add a title that will appear above the TOC.

☐ if you are using Camtasia 7.1, click the Flash options button; if you are using version 7.0, you should already be in the Flash Options dialog box

☐ select the Table of Contents tab

☐ in the Title Area, type Working with Folders

5. Change the TOC Display options.

☐ on the Table of Contents tab, select Fixed-right from the Display options at the bottom of the dialog box

☐ click the OK button

☐ click the Next button

You should now be on the Video Options screen of the Production Wizard.

☐ click the Next button

And finally, you’re on the Produce Video screen.

☐ change the Production name to MarkMe_TOCMMe2

☐ click the Finish button

Your new video will be rendered.
☐ click the **Play** button to start the video

Your updated TOC should appear (wider and at the right of the video). And check out the title bar above the TOC. You’ll see the title you added.

6. Close the browser window.

7. Close the Production Results dialog box.

8. Save your work.
**Confidence Check**

1. Produce the video again using **Custom production settings**.

2. This time, when you get to the Flash Templates screen, change the Template to **One video with TOC**.

3. Select **Glass** from the Themes drop-down menu.

4. Click the **Flash options** button and select the **Controls** tab.

5. From the Playback controls area, select **Show about box**.

6. Type **A presentation developed by** and then type **your full name**.

7. Click the **OK** button.

8. At the bottom left of the Flash Templates screen, click the **Preview** button and choose **Preview current settings**.

   The Preview feature generates your project files to My Documents\Camtasia Studio\Production Previews. You will usually find that previewing your video is faster than waiting for the video to render (only to find problems and have to render the video over again). Previews give you a good feel for how your finished videos will look and behave. However, previews are not the same quality as rendered videos. When ready to finish your project, you should always render the video.

9. In the browser window that displays your preview, click the button in the lower right of the Playbar to see the information you typed a moment ago.

10. Close the browser window and return to Camtasia (the Production Wizard should still be open on the Flash Templates screen).

11. Click the **Next** button (you should now be on the Video Options screen).
12. Click the HTML options button at the right and change the Title to **Working with Folders**.

13. Click the **OK** button, click **Next** a couple of times and then click the **Finish** button to render the video (you can overwrite the existing file when/if prompted).

14. Play the video. The big thing to notice this time is your browser’s title bar (or the tab title, depending on the Web browser you are using and its version). You’ll see the page title that has been added thanks to the Title you just added.

15. Close the browser window.

16. Back in Camtasia, click the **Finish** button.

17. Save your work.
Hotspots

To maximize the effectiveness of your eLearning videos, you can add interactivity via a Flash Hotspot. The hotspots you add can allow your customers to jump to specific markers within a video, add hyperlinks to Web sites and more.

Several callouts can include a Flash Hotspot (by selecting Make Flash Hotspot). The option is automatically included if you use a Transparent Hotspot, which you will be adding to the project soon.

Here are the options available to you when you create a Flash Hotspot:

**Pause at end of callout:** Once clicked, the video will stop based on the callout’s end time on the Timeline.

**Click to continue:** The viewer must click the callout to continue viewing the video.

**Go to frame at time:** The video jumps to a specific frame. You can enter the frame to jump to in Hours:Minutes:Seconds:Frames.

**Go to marker:** The video jumps to a specific Timeline marker.

**Jump to URL:** Opens a Web page (enable the Open URL in a new browser window to open the Web page in a separate window).

*Note:* To include a Flash Hotspot in your video, you must produce to the Flash output (MPEG-4 or SWF).

**Student Activity: Replace a Background Image**

1. Using Camtasia Studio 7, open `FlashHotSpotMe.camproj` from the Camtasia7Data folder.

2. Open a Title Clip for editing.
   - at the beginning of the Video 1 Track on the Timeline, double-click the first Title Clip
   - The Title Clip’s Properties appear.

3. Replace a background image.
   - in the Background area, click the yellow folder at the right of the Image field
   - from the Camtasia7Data/images folder, open BeginScreen.jpg

On the Preview panel, notice that the background image has been replaced. This new one includes a “Begin Lesson” image in the lower right of the screen. You will be adding a Flash Hotspot on top of the image of the button. Your customers will be able to click the hotspot to begin the lesson.
Student Activity: Add a Transparent Hotspot

1. The FlashHotSpotMe project should still be open.

2. Add a Transparent Hotspot Callout.
   - select the Playhead at the beginning of the Timeline, choose Tools > Callouts
   - click the Add callout button
   - click the button in the lower right of the Shapes panel to display all of the shapes
   - select Transparent Hotspot

   On the Timeline, your new caption appears on the Callouts Track just beneath the image on the Video 1 Track.

3. Set the Callout Properties.
   - if necessary deselect both Fade in and Fade out from the Properties area

4. Size and position the callout on the Preview.
   - move and resize the callout until both the size and position are similar to the picture below
Student Activity: Set Flash Hotspot Properties

1. The FlashHotSpotMe project should still be open.

2. Set the Flash Hotspot Properties.
   - on the Timeline, double-click the Transparent Hotspot Callout you just added (to ensure the Callout’s Properties are open)
   - click the Flash hotspot properties button

   ![Flash hotspot properties dialog box]

   - from the Action area, select Go to marker
   - select Begin Lesson from the marker drop-down menu (you learned how to create markers on page 126)

   - click the OK button

3. Save your work.
Confidence Check

1. Still working in the FlashHotSpotMe project, double-click the last object on the Timeline.
2. Insert a second Transparent Hotspot Callout.
3. Resize the new callout so that it is as large as the preview screen.
4. Set the Flash hotspot properties to Jump to URL and type http://www.southrivertechnologies.com into the text field.
5. Ensure Open URL in new browser window is selected.
6. Click the OK button.
7. If necessary, change the Properties of the new callout so that it does not Fade in or Fade out.
8. On the Timeline, stretch the new callout right so that it ends when the video ends.
9. Produce the video (select Web from the drop-down menu).

10. Watch the produced video and test the first hotspot (the first hotspot should simply start the lesson).

When you click the second hotspot, there’s a good chance you’ll see the Adobe Flash Player Security dialog box.

So what’s the deal with the dialog box above? The Flash Player was designed to provide security settings that do not require you to explicitly allow or deny access in most situations. Over time, as SWF and FLV content have become more sophisticated, the Flash Player has also become more sophisticated, offering additional privacy and security protections.

The content you just published was created using older security rules. You can allow the content to work as the Camtasia developers intended, using the older security rules, or you can choose to enforce the newer, stricter rules. The latter choice helps ensure that you only view or play content that meets the most recent standards of security, but it may sometimes prevent your video from working properly.

When some content runs in a newer version of the player, and the Flash Player needs you to make a decision about enforcing newer rules or not, you may see the dialog box on the previous page that asks your permission before allowing the older SWF or FLV content to communicate with other locations on the Internet.

Rest assured that your customers will not see the dialog box once your published content is posted on a secure Web server. However, the following steps will help you get past the Flash Security Warning on your computer.

Note: If you did not see the message at the left, you can manually browse to the Settings screen shown on the next page via this URL: http://bit.ly/16SwkR.
11. Click the **Settings** button to open the **Global Security Settings** page (or start your default Web browser and go to [http://bit.ly/16SwkR](http://bit.ly/16SwkR)).

![Global Security Settings](image)

**Note:** You can manually browse to the Settings screen shown at the left via this URL: [http://bit.ly/16SwkR](http://bit.ly/16SwkR).

12. From the Adobe Flash Player Settings Manager, click **Always allow**.

13. Click **Edit locations** and then click **Add location**.

14. In the Trust This Location dialog box, click the **Browse for folder** button.

15. Open the **Camtasia7Data** folder and click the **OK** button.

![Add Location](image)

16. When finished, close all browser windows.

17. Click the **Open production folder** button on the Production Results dialog box (this will open the FlashHotSpotMe folder).

18. From the FlashHotSpotMe folder, open **FlashHotSpotMe.html**

19. Test the second hotspot.

   The hotspot should open the Web browser and SRT home page without incident.

20. When finished, close all browser windows and close the Production Results dialog box.

21. Save your work.